Officially recommended version?

Greetings,

I’ve been going nuts over the past few weeks why new users end up with
gnuradio 3.6. Clearly, some of them want to use some funky stuff that
has not yet been ported to 3.7, but there are also others who are just
clueless and end up with 3.6 by following the instructions.

Indeed, according to
http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR
The recommended way to install is the build-gnuradio script and this
script installs the latest 3.6 release. There is no option to install
the latest 3.7 release and there is no option to uninstall previously
installed 3.6!

This may have worked six months ago when there was only 3.6, but it is
not acceptable today - unless 3.6 really is the recommended version,
which in turn would make me feel like an idiot for distributing stuff
that requires 3.7…

Anyway, I don’t mind having the build-gnuradio script as the
recommended tool for installing gnuradio but it should at least offer
the latest 3.7 release and force the user to make a decision whether
to install 3.6, 3.7 or master.

Finally, it is unclear to me what the recommended way to uninstall
gnuradio is when using this script. I’ve seen some people talk about
an “uninstall-gnuradio” script but I can’t find any official reference
to that.

Alex

On 09/16/2013 10:40 AM, Alexandru C. wrote:

script installs the latest 3.6 release. There is no option to install
the latest 3.7 release and force the user to make a decision whether
Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
build-gnuradio -m installs 3.7

There’s still a metric ass-tonne of Gnu Radio stuff out there (including
my own applications) that is for 3.6, which is why the default for
build-gnuradio
is to install 3.6.5.1

Hi,

I think it’s clear that any new development should be done on 3.7 and
people still having 3.6 projects should be working on migration (if
those projects are still considered active/maintained).

However it’s pretty evident that it’s not going to happen overnight
and so currently the only viable option for users that don’t have one
particular application in mind is to have both installed and using
different prefixes which unfortunately build-gnuradio doesn’t support.

Cheers,

Sylvain

Hi,

Anyway, I don’t mind having the build-gnuradio script as the recommended
tool
for installing gnuradio but it should at least offer the latest 3.7
release and force
the user to make a decision whether to install 3.6, 3.7 or master.

It offers the option, but only for those who know it, by using the -m
option. However I agree it would be nicer if it actively asked, " do you
want to install 3.6 or 3.7 latest build?".

Ralph.

You know there’s --help right?


Principal Investigator
Shirleys Bay Radio
Astronomy Consortium
http://www.sbrac.org

Of course, but one who has no idea of the different versions sees no
need to
check what exactly -m is :slight_smile:

Ralph.

On Mon, Sep 16, 2013 at 5:09 PM, Marcus D. Leech [email protected]
wrote:

http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR
Anyway, I don’t mind having the build-gnuradio script as the

It was my understanding that -m installs the git head and not the
latest 3.7 release. IMHO, git head does not qualify as a stable
baseline for application development and distribution.

There’s still a metric ass-tonne of Gnu Radio stuff out there (including my
own applications) that is for 3.6, which is why the default for
build-gnuradio is to install 3.6.5.1

My problem is not so much with the script itself as with the fact that
it is the recommended way to install. Maybe it is unintentional and a
forgotten leftover from the 3.6-days. That is why I am asking for an
official opinion, if there is any.

It also appears that many fedora and ubuntu versions now come with
gnuradio 3.6.5 packaged.

Alex

On Mon, Sep 16, 2013 at 5:32 PM, Sylvain M. [email protected]
wrote:

Hi,

I think it’s clear that any new development should be done on 3.7 and
people still having 3.6 projects should be working on migration (if
those projects are still considered active/maintained).

However it’s pretty evident that it’s not going to happen overnight
and so currently the only viable option for users that don’t have one
particular application in mind is to have both installed and using
different prefixes which unfortunately build-gnuradio doesn’t support.

It’s not an issue for development but for distribution. As it is right
now you can not even distribute a simple grc flowgraph without
explicit instructions about which version it requires and how to
install it.

Alex

On Mon, Sep 16, 2013 at 5:07 PM, Alexandru C. [email protected]
wrote:

Indeed, according to

build-gnuradio -m installs 3.7
My problem is not so much with the script itself as with the fact that
it is the recommended way to install. Maybe it is unintentional and a
forgotten leftover from the 3.6-days. That is why I am asking for an
official opinion, if there is any.

It also appears that many fedora and ubuntu versions now come with
gnuradio 3.6.5 packaged.

Alex

Hi Alex,

It’s actually left over from the very early post-3.7 days. Because of
the many OOT projects using 3.6 (or earlier), we wanted to let things
settle out before defaulting everyone to 3.7. But from all of the talk
on the list and from what I’ve heard, it sounds like many of the
projects people use and are interested in have been moving over to
3.7. It’s past time to update that language on the website.

This topic is on the agenda for Thursday’s developers call. I just
want to get any more feedback on the issue before we change things. My
thinking right now is that we basically just add an explanation of the
3.6 vs 3.7 to the download page on the website and also how to get the
different versions using the different tools. I just want to talk
about this out loud on the call to make sure I don’t miss anything.

On the other hand, I put PyBOMBS above the build-gnuradio script to
suggest using the new tool over the build script. But as PyBOMBS
was/is new and because of the conversion of OOT projects to 3.7, I
left the language that build-gnuradio is the preferred method in
there.

But it’s time to update. Thanks for bringing up the conversation.


Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13

On Tue, Sep 17, 2013 at 4:30 PM, Tom R. [email protected] wrote:

that requires 3.7…

want to get any more feedback on the issue before we change things. My

But it’s time to update. Thanks for bringing up the conversation.

Hi Tom,

Thanks for the info. I think adding a note about 3.6 vs 3.7 would be a
good step in the right direction.

Alex

Yes, it is extremely frustrating that the developers keep releaseing new
versions of Gnuradio and break all the previous stuff and don’t have the
resources to produce documentation. This is why Gnuradio is still not
suitable for production systems. 3.6 could have been - but not they had
to change it and fiddle rather than fix what was already there.

I am using 3.6. I tried 3.7 but a bunch of stuff would not compile due
to things removed, principally gruel.

Unfortunately, I just don’t have the time to keep up with all the
developments. I really appreciate all the effort the team is putting in
to develop this open source software but as it is, Gnuradio is strictly
for the hacker and that should be made clear in big red letters on the
wiki, in bold, underlined and flashing.

Mike

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs