OFDM sync ml

Hi,
thank you a lot for your advice of OFDM packets.
I try ofdm system with default parameters and the result is good.(PN
synchronization)

I have been trying to test Ofdm system shift into rx sync. The test
failed when
I change sync in receive.py ( for example ml).

I use realese number 7324 and kubuntu 7.04

Each time I run benchmark_ofdm_rx.py I get;

Traceback (most recent call last):
File “benchmark_ofdm_rx.py”, line 210, in
main()
File “benchmark_ofdm_rx.py”, line 199, in main
tb = my_top_block(rx_callback, options)
File “benchmark_ofdm_rx.py”, line 64, in init
self.rxpath = receive_path(callback, options)
File “/home/crespi/Desktop/Workspace_flo/receive_path.py”, line 52, in
init
blks2.ofdm_demod(options, callback=self._rx_callback)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/blks2impl/ofdm.py”,
line
209, in init
self.ofdm_recv = ofdm_receiver(self._fft_length,
self._cp_length,self._occupied_tones, self._snr, preambles,options.log)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/blks2impl/ofdm_receiver.py”,
line 107, in init
self.connect((self.ofdm_sync,1), (self.ofdm_frame_acq,1))
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/hier_block2.py”,
line
70, in connect
self._connect(points[i-1], points[i])
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/hier_block2.py”,
line
76, in _connect
dst_block.basic_block(), dst_port)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/gnuradio_swig_py_runtime.py”,
line 946, in connect
return _gnuradio_swig_py_runtime.gr_hier_block2_sptr_connect(*args)
ValueError: port number 1 exceeds max of 0

Thank you all for help us!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs