Odd diagnostics when I installed 'rake' like on page 217 PAB


#1

root@baldwin:~# gem install -r rake
Attempting remote installation of ‘rake’
Successfully installed rake-0.7.1
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- rdoc/rdoc (LoadError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:43:in
generate_rdoc' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:215:inexecute’
from
/usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:214:in each' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:214:inexecute’
from
/usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:153:in each' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:153:inexecute’
from /usr/local/lib/site_ruby/1.8/rubygems/command.rb:49:in
invoke' from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:94:inprocess_args’
from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:67:in
run' from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:13:inrun’
from /usr/bin/gem:17

EOM


#2

Xeno C. wrote:

root@baldwin:~# gem install -r rake
Attempting remote installation of ‘rake’
Successfully installed rake-0.7.1
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__’: no such file to load – rdoc/rdoc (LoadError)

Looks like you don’t have rdoc installed. Since rdoc is a standard part
of the ruby distribution, I’m guessing that you are running ruby on a
debian or debian based system that has split up standard ruby into
multiple packages.

Check your distribution packages for the ruby/rdoc package. You might
want to double check for other things that are missing as well.


– Jim W.