Occasional choppiness/underruns (aUaU) with FCDPP->GRC->Pulse

Chuck,

In most cases the problem comes from ALSA. If you’re able to change ALSA
to
something else, try to change it.

If you can’t change your default sound driver then you may try using
“-Dplug:default” option for aplay. If you need to use this option with a
Python script you may use it like " -c plug:default".

This was my only solution when I tried running rtl_fm on Raspberry
because
default audio driver of Raspberry is ALSA and not possible to change
(everything else like Jack, Pulseaudio etc. can’t be a solution because
all
of them run over ALSA, ALSA always remains at the bottom, so the problem
always remain).

I hope this helps.

Regards,

Murat, TA1DB

From: Chuck R. [via GnuRadio]
[mailto:[email protected]]

Sent: Sunday, April 06, 2014 4:10 AM
To: Murat TA1DB
Subject: Occasional choppiness/underruns (aUaU) with FCDPP->GRC->Pulse

Hello list, I need some help.

When running GRC 3.6.1 I am getting a problem with occasional choppiness
in
my audio output. Details:

  • The choppiness sounds like only part of the buffer is filling, similar
    to
    the sound you get when a filmstrip’s playback gets unstable and you get
    that
    ‘jitter’

  • The issue usually does not immediately occur however occurs a few
    minutes
    into use.

  • Sometimes computer activity such as un-minimizing a window will
    trigger
    the problem. Sometimes the same will fix it.

  • Input is Funcube Dongle Pro+ 192khz on alsa hw:3

  • Occurs regardless of using FCDPP+ Block or the Audio Input block.

  • Output is pulse, originally set to 192khz (pulse resamples it),
    brought it
    down to native 48khz and used Rational Resampler block to bring the 192
    to

  1. Did not resolve, however the issue occurred less often. (still
    intolerable)
  • Turned on Realtime Scheduling and then adapted the JACK instructions
    for
    enabling system realtime scheduling permissions
    (http://jackaudio.org/linux_rt_config). Afterward confirmed the python
    process to have a nice of -30 which is realtime. Issue did not resolve
    but
    again, it happened less often. (still intolerable)

  • Occurs regardless of graph complexity. Simple in->out arrangement will
    reproduce issue.

  • Sometimes you can hear it get worse as time goes by, and sometimes it
    will
    just as randomly fix itself, only to occur again later.

  • I am using pulse as my audio output.

  • When the issue occurs, the console output in GRC fills rapidly with
    “aUaU”

  • When the issue occurs, looking into pavucontrol playback tab shows
    “ALSA
    plug-in [python 2.7]” entry flickering rapidly, as if it is resetting
    its
    connection over and over in an unreasonable manner.

  • When the issue occurs, the realtime python process on core 2 shows no
    change in core usage, however the non-realtime gnuradio-companion
    process,
    also on core 2, spikes from its usual 0.9% usage to 93%. The only way I
    can
    see a high-priority process being pushed out by a low-priority process
    is if
    the high-priority process is waiting on the low-priority process for
    some
    operation to complete (this is a DSP no-no).

  • When the issue occurs, pulseaudio’s verbose log fills rapidly.
    attached is
    a snippet of what repeatedly fills the log.

  • There is chatter about similar underrun issues with mozilla and pulse.
    However the fixes appear to be occurring in mozilla only so there wasn’t
    much help from that.
    (https://bugzilla.mozilla.org/show_bug.cgi?id=779392)

  • When attempting to specify ‘pulse’ as signal input in GRC and then
    specify
    FCDPP as its input in pavucontrol, GRC gives silence and a stream of
    “aU”

  • pulseaudio 4.0

  • Xubuntu 13.10 AMD64.

There was a similar issue posted earlier however it was different in
nature
in the sense that the underruns occurred immediately instead of on
occasion,
implying a consistent sample rate mismatch.
https://lists.gnu.org/archive/html/discuss-gnuradio/2013-08/msg00516.html

It is reasonable to rule out sample-rate mismatch in my case as the
issue
occurs only on occasion and sometimes fixes on its own, a mismatch would
be
expected to immediately fail. It would be mathematically impossible for
a
mismatched sample rate to cause such cascading underruns after minutes
of
proper functioning except for clock drift, which would be expected to be
solved with a single buffer reset (a slight “blip”). This is not what is
happening. It is thousands of consecutive blips after a while of proper
functioning.

Thanks for reading. Log dump attached.


Discuss-gnuradio mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

http://gnuradio.4.n7.nabble.com/images/icon_attachment.gif
grc-jitter-bug-pulse.log (15K) Download Attachment
<http://gnuradio.4.n7.nabble.com/attachment/47411/0/grc-jitter-bug-pulse.log


If you reply to this email, your message will be added to the discussion
below:

http://gnuradio.4.n7.nabble.com/Occasional-choppiness-underruns-aUaU-with-FC
DPP-GRC-Pulse-tp47411.html

To start a new topic under GnuRadio, email [email protected]
To unsubscribe from GnuRadio, click here
<http://gnuradio.4.n7.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_
by_code&node=2&code=bXRvbG9nbHVAaG90bWFpbC5jb218MnwtNTYyNDcwMzM2> .

<http://gnuradio.4.n7.nabble.com/template/NamlServlet.jtp?macro=macro_viewer
&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicName
space-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.Node
Namespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_email
s%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml> NAML

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs