Observe_field Error: Se requiere un objeto

El Internet Explorer está reportando el error “Se requiere un objeto”,
lo está provocando observe_field.

En la vista:

<%= javascript_include_tag :defaults %>

<%= observe_field(:producto_unidades, :frequency => 0.5, :update =>
:div_change_unidades, :url => { :action => :change_unidades }) %>

<%= text_field ‘producto’, ‘unidades’, :maxlength => 6 %>

productos_controller.rb

def change_unidades
render :layout => false
end

change_unidades.rhtml

PRUEBA

De antemano agradezco la ayuda.

Saludos

Jaime Mora R.

On 5/4/07, Jaime Mora R. [email protected] wrote:

:div_change_unidades, :url => { :action => :change_unidades }) %>

change_unidades.rhtml

PRUEBA

De antemano agradezco la ayuda.

Saludos

Jaime Mora R.

La llamada a observe_field debería estar debajo de la llamada a
text_field. Supongo que es a eso a lo que el Explorer se refiere (lo
que me extraña es que en otros navegadores te funcione).

Daniel R. Troitiño wrote:

La llamada a observe_field deberí¡ estar debajo de la llamada a
text_field. Supongo que es a eso a lo que el Explorer se refiere (lo
que me extrañ¡ ¥s que en otros navegadores te funcione).

Solucionado. Unicamente lo he probado en este navegador, gracias por tu
valiosa ayuda.

Saludos.

Jaime Mora R.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs