Nubie question

So I am considering switching my site over to typo and have set it up
to test. After doing that I have encountered a few problems that I
cannot seem to over come.

My assumption is that the problems are all caused by the same thing
(probably something I do not have installed but need).

First let me say I am testing this on an Ubuntu box.

I have installed all the dev packages needed to compile the native
extensions (I believe). I have also installed gems using the ubuntu
package (which is version 0.9.0, however I have also updated it to the
latest version with no change in the results).

Ruby is 1.8.5 (also from a package).

So I “gem install typo” and it installs all the required dependencies.
once that is done I run “typo install Blog” and it creates all the
files, however at the end it gives me the message " Running tests.
This may take a minute or two
***** Tests failed *****
** Please run ‘rake test’ by hand in your install directory.
** Report problems to the Typo mailing list.
***** Tests failed *****"

Which is my first clue that something is wrong.

If I run rake test it fails on about 95% of the tests (that is an
estimate). Even given that I try to run it. It runs fine except for
when trying to go to http://localhost:4134/admin/content/new which
gives me the error no such file to load – content_state/null, with a
nice trace.

I’ve tried everything I can think of to get this running with no
success. Does anyone have any ideas/suggestions?

When this is all said and done it’ll be running on a debian machine,
however I need to rebuild that box and am unable to test it on that at
the moment.

Problems are often in database.yml

This install tutorial is specific to running typo in production mode,
but it covers most of the pitfalls:

It turns out you are correct, I would have thought the default setup
(which uses SQLite3) would have worked, but I changed to to MySQL and
all the problems went away.

Thanks for the pointer.