Not responding B100

Hi List,

My B100 suddenly stopped responding to UHD init.
It appears that the USB interface actually lost its ability to identify
as
a device.
Here below, you can find the output of the fedora “messages” log for
the Broken B100 as well as for a working one.

Could this be solved by re-programming the USB interface somehow?

my best regards

vince


Bricked B100

Sep 9 17:43:25 vince kernel: [293521.821638] usb 1-1.2: USB disconnect,
device number 23
Sep 9 17:43:28 vince kernel: [293524.558326] usb 1-1.2: new high-speed
USB
device number 25 using ehci_hcd
Sep 9 17:43:28 vince kernel: [293524.643549] usb 1-1.2: New USB device
found, idVendor=0a00, idProduct=0002
Sep 9 17:43:28 vince kernel: [293524.643554] usb 1-1.2: New USB device
strings: Mfr=0, Product=0, SerialNumber=0
Sep 9 17:43:28 vince mtp-probe: checking bus 1, device 25:
“/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2”
Sep 9 17:43:28 vince mtp-probe: bus: 1, device: 25 was not an MTP
device

Good B100

Sep 9 17:43:28 vince mtp-probe: bus: 1, device: 25 was not an MTP
device
Sep 9 17:43:58 vince kernel: [293555.356431] usb 1-1.2: USB disconnect,
device number 25
Sep 9 17:44:17 vince kernel: [293573.964334] usb 1-1.2: new high-speed
USB
device number 26 using ehci_hcd
Sep 9 17:44:17 vince kernel: [293574.050317] usb 1-1.2: New USB device
found, idVendor=2500, idProduct=0002
Sep 9 17:44:17 vince kernel: [293574.050322] usb 1-1.2: New USB device
strings: Mfr=1, Product=2, SerialNumber=6
Sep 9 17:44:17 vince kernel: [293574.050326] usb 1-1.2: Product: USRP
B1004
Sep 9 17:44:17 vince kernel: [293574.050328] usb 1-1.2: Manufacturer:
Ettus R. LLC
Sep 9 17:44:17 vince kernel: [293574.050330] usb 1-1.2: SerialNumber:
E8R10ZFB1
Sep 9 17:44:17 vince mtp-probe: checking bus 1, device 26:
“/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2”
Sep 9 17:44:17 vince mtp-probe: bus: 1, device: 26 was not an MTP
device
Sep 9 17:44:49 vince kernel: [293606.298898] usb 1-1.2: USB disconnect,
device number 26

Hi Tapiwa,

There should be object code for fixing the B100 USB interface in the UHD
tree under /host/build/utils.

cmake compiled it for you when you built the whole UHD.

The bin file to use is fx2_init_eeprom.
Use the --help option to get usage info.

You also need the suitable b100_boot.bin and b100_eeprom.bin
to be flashed into the B100.

I’m actually having those but I’m not sure whether or not they’re
the good version for your board revison.
I’m actually haning no clue on the versioning of such files.
Seeking advice from other list members on this.

Best

Vincenzo
Il giorno 13/mag/2014 12:10, “Tapiwa Chiwewe” [email protected]
ha
scritto:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs