Not able to run ERB

I compliled Ruby 1.9.2.p0 tar and installed with
make&&make install.

When I try to run the command erb I get this

[[email protected] ruby-1.9.2-p0]# …/bin/erb
internal:lib/rubygems/custom_require:29: [BUG] iseq_compile_each:
unknown node: NODE_SCOPE
ruby 1.9.2p0 (2010-08-18) [x86_64-linux]

– control frame ----------
c:0005 p:---- s:0015 b:0015 l:000014 d:000014 CFUNC :require
c:0004 p:0013 s:0011 b:0011 l:000010 d:000010 METHOD <internal:lib/
rubygems/custom_require>:29
c:0003 p:0011 s:0006 b:0006 l:002318 d:000a98 EVAL /usr/bin/erb:6
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:002318 d:002318 TOP

– Ruby level backtrace information

/usr/bin/erb:6:in <main>' <internal:lib/rubygems/custom_require>:29:inrequire’
internal:lib/rubygems/custom_require:29:in `require’

– C level backtrace information

/usr/bin/ruby(rb_vm_bugreport+0xb5) [0x523095]
/usr/bin/ruby [0x561066]
/usr/bin/ruby(rb_bug+0xb1) [0x5611d1]
/usr/bin/ruby [0x4f42c8]
/usr/bin/ruby(rb_iseq_compile_node+0x266) [0x500d06]
/usr/bin/ruby(rb_iseq_new_with_opt+0xbc) [0x5075bc]
/usr/bin/ruby [0x4f6418]
/usr/bin/ruby [0x4f43a4]
/usr/bin/ruby(rb_iseq_compile_node+0x62c) [0x5010cc]
/usr/bin/ruby(rb_iseq_new_with_opt+0xbc) [0x5075bc]
/usr/bin/ruby [0x4f78d7]
/usr/bin/ruby [0x4f43a4]
/usr/bin/ruby(rb_iseq_compile_node+0x520) [0x500fc0]
/usr/bin/ruby [0x50601d]
/usr/bin/ruby(rb_iseq_new_top+0x2c) [0x5062ec]
/usr/bin/ruby [0x563b05]
/usr/bin/ruby(rb_require_safe+0x665) [0x5650a5]
/usr/bin/ruby [0x50c9a5]
/usr/bin/ruby [0x5100c7]
/usr/bin/ruby [0x5169a9]
/usr/bin/ruby(rb_iseq_eval_main+0x1d4) [0x516c84]
/usr/bin/ruby [0x417bbf]
/usr/bin/ruby(ruby_run_node+0x36) [0x41a386]
/usr/bin/ruby(main+0x4d) [0x416e4d]
/lib64/libc.so.6(__libc_start_main+0xf4) [0x39eb61d994]
/usr/bin/ruby [0x416d49]

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension
libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Aborted

=======================================================

Could someone help me understand what is wrong? ruby command works
perfectly. But gem also gives similar error

[[email protected] ruby-1.9.2-p0]# gem -v
internal:lib/rubygems/custom_require:29: [BUG] Segmentation fault
ruby 1.9.2p0 (2010-08-18) [x86_64-linux]

– control frame ----------
c:0005 p:---- s:0018 b:0018 l:000017 d:000017 CFUNC :require
c:0004 p:0013 s:0014 b:0014 l:000013 d:000013 METHOD <internal:lib/
rubygems/custom_require>:29
c:0003 p:0011 s:0009 b:0009 l:000438 d:001a00 EVAL /usr/bin/gem:8
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:000438 d:000438 TOP

– Ruby level backtrace information

/usr/bin/gem:8:in <main>' <internal:lib/rubygems/custom_require>:29:inrequire’
internal:lib/rubygems/custom_require:29:in `require’

Segmentation fault

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs