Non upgradate a 2.3.5

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

2010/1/5 Alessandro S. [email protected]:

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

per pura curiosità, potresti fare qualche esempio ?

michele

Michele F. wrote:

2010/1/5 Alessandro S. [email protected]:

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

per pura curiosit�, potresti fare qualche esempio ?

michele

#ActionController::Routing.generate_best_match = false

questa ad esempio, più il famigerato problema di

`require_frameworks’:RuntimeError: RubyGem version error: rack(1.0.0 not
~> 1.0.1)

che non funziona neanche se hai rack 1.1.0 installato …

insomma un parto…(come sempre :stuck_out_tongue: )

2010/1/5 Alessandro S. [email protected]

questa ad esempio, più il famigerato problema di

`require_frameworks’:RuntimeError: RubyGem version error: rack(1.0.0 not
~> 1.0.1)

che non funziona neanche se hai rack 1.1.0 installato …

insomma un parto…(come sempre :stuck_out_tongue: )

scusa, ma che intendi per un parto? come sempre…

sul sito dice:
Rails 2.3.5 was released over the weekend which provides several
bug-fixes
and one security
fixhttp://groups.google.com/group/rubyonrails-security/browse_thread/thread/4d4f71f2aef4c0ab.
It should be fully compatible with all prior 2.3.x releases and can be
easily upgraded to with “gem update rails”. The most interesting bits
can be
summarized in three points.

mi aspetto che quindi se fai l’update non ci dovrebbero essere problemi,
è
rilasciato stabile e inoltre dice che hanno solo risolto i bugs…

Alessandro S. wrote:

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

Boh qui appena era uscito ho aggiornato cambiando due numeri in cima a
environment.rb e tutto funzionato al primo colpo. In pratica YMMV.

Simone F. wrote:

2010/1/5 Alessandro S. [email protected]

questa ad esempio, più il famigerato problema di

`require_frameworks’:RuntimeError: RubyGem version error: rack(1.0.0 not
~> 1.0.1)

che non funziona neanche se hai rack 1.1.0 installato …

insomma un parto…(come sempre :stuck_out_tongue: )

scusa, ma che intendi per un parto? come sempre…

sul sito dice:
Rails 2.3.5 was released over the weekend which provides several
bug-fixes
and one security
fixhttp://groups.google.com/group/rubyonrails-security/browse_thread/thread/4d4f71f2aef4c0ab.
It should be fully compatible with all prior 2.3.x releases and can be
easily upgraded to with “gem update rails”. The most interesting bits
can be
summarized in three points.

mi aspetto che quindi se fai l’update non ci dovrebbero essere problemi,
è
rilasciato stabile e inoltre dice che hanno solo risolto i bugs…

bhe io per rendere una mia applicazione (abbastanza complessa)
compatibile ho perso 1 ora di debugging e ho dovuto commentare delle
parti di codice nuovo…

Nessun cambio di versione è mai stato indolore e mai lo sarà , ad
esempio, ieri è uscita la versione 0.7 di prawn, il release notes dice
“non compatibile con la 0.6” solo che se ti servono le nuove
funzionalità che hanno inserito ti tocca aggiornare… :slight_smile:

2010/1/7 Andrea L. [email protected]:

Alessandro S. wrote:

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

Boh qui appena era uscito ho aggiornato cambiando due numeri in cima a
environment.rb e tutto funzionato al primo colpo. In pratica YMMV.

me too.

michele.

Alessandro, su che versione eri prima della 2.3.5?

Michele F. wrote:

2010/1/7 Andrea L. [email protected]:

Alessandro S. wrote:

a me la 2.3.5 ha fatto solo casini… ho dovuto commentare dei pezzi di
initializer e altro…

Boh qui appena era uscito ho aggiornato cambiando due numeri in cima a
environment.rb e tutto funzionato al primo colpo. In pratica YMMV.

me too.

michele.

Idem, e ne ho portate parecchie dalla 2.3.4 alla 2.3.5

Paolo

Luca G. wrote:

Alessandro, su che versione eri prima della 2.3.5?

2.3.3

Bho se a tutti non da problemi tranne che a me sarò io il solito sfigato
allora :slight_smile:

non te la prendere, almeno è un buona notizia…
se esce una minor release non ci possono/devono essere cambiamenti
strutturali
sapere che non vengono fatti rilasci alla carlona mi rassicura :smiley:
S

Simone F.

Software Architect

2010/1/7 Alessandro S. [email protected]

Idem,

ho provato anche a disinstallare tutte le versioni di rack e a rimettere
la 1.0.1 ma continua a non andare.

Bho se a tutti non da problemi tranne che a me sarò io il solito sfigato
allora :slight_smile:

Eh, effettivamente hanno sbagliato qualcosina. E` appena capitato
anche a me. La soluzione:

gem1.8 install rack --version 1.0.1


David N. Welton

http://www.welton.it/davidw/

http://www.dedasys.com/
Sent from Padova, PD, Italy

Alessandro S. wrote:

Yuri R. wrote:

Idem,

ho provato anche a disinstallare tutte le versioni di rack e a rimettere
la 1.0.1 ma continua a non andare.

prova a togliere tutti i rack e a reinstallare rails 2.3.5 dovrebbe
andare (così rack se lo installa lui)

Ho notato però che la cosa accade solo utilizzando JRuby, sviluppando
con la MRI invece non ho problemi.

Yuri R. wrote:

Idem,

ho provato anche a disinstallare tutte le versioni di rack e a rimettere
la 1.0.1 ma continua a non andare.

prova a togliere tutti i rack e a reinstallare rails 2.3.5 dovrebbe
andare (così rack se lo installa lui)

Yuri R. wrote:

Alessandro S. wrote:

Yuri R. wrote:

Idem,

ho provato anche a disinstallare tutte le versioni di rack e a rimettere
la 1.0.1 ma continua a non andare.

prova a togliere tutti i rack e a reinstallare rails 2.3.5 dovrebbe
andare (così rack se lo installa lui)

Ho notato però che la cosa accade solo utilizzando JRuby, sviluppando
con la MRI invece non ho problemi.

io non uso jruby e mi è capitato, non su tutti i sistemi, circa sul 40%
(ho 7 macchine con ruby, 3 su 7)

Alessandro S. wrote:

Yuri R. wrote:

Alessandro S. wrote:

Yuri R. wrote:

Idem,

ho provato anche a disinstallare tutte le versioni di rack e a rimettere
la 1.0.1 ma continua a non andare.

prova a togliere tutti i rack e a reinstallare rails 2.3.5 dovrebbe
andare (così rack se lo installa lui)

Ho notato però che la cosa accade solo utilizzando JRuby, sviluppando
con la MRI invece non ho problemi.

io non uso jruby e mi è capitato, non su tutti i sistemi, circa sul 40%
(ho 7 macchine con ruby, 3 su 7)

Il fatto è che sono nuovo di Linux e ho sputato sangue per avere una
postazione pseduo-funzionante tra i vari software e pacchetti.

Sarà ma con Win Vista e Seven mica ho avuto tutti sti problemi. d’oh!!

Ci penso 10 volte quindi adesso prima di disinstallare/installare
qualcosa. :smiley:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs