NoMethodError problem


Id like you to help me with something here, i m trying to create a log
manager just for fun but I cant make it work since the beginning.
I created my project, configured the db, initialized my model Log and
then my controller Log, then im just trying to use scaffold :log for the
controller but I cant make it work, the error says:

undefined method `errors’ for #WEBrick::Log:0x37f7760

and a bunch of errors like:

The database contains a table with 5 fiels, just the regular stuff,
id,title,content,poster,date, any idea why this thing isnt working?



On Dec 29, 2005, at 12:04 AM, Paulino Calderon wrote:

and a bunch of errors like:

Rails mailing list


It looks like you are running into a reserved word 'Log' webrick

uses that internally. So you will need to change that to something
else. Maybe MyLog or whatever you come up with. That should get you
over the hump.


-Ezra Z.
Yakima Herald-Republic Newspaper


Thanks! That solved the problem, i definetly need to learn more about
ruby now.


I have the same problem, only I’m following the instructions witht the
“Rolling with Ruby on Rails” tutorial. I have tried creating additional
models and correponding controllers, but I get the same error, so I
don’t think a reserved word is the problem.

Can anyone help a Rails beginner?