NoMethodError in action_view/helpers/form_helper.rb:302:in `

Hello everyone

I have this rather strange problem. After updating rails from 1.1.6 to
1.2.2 I get these errors when using check_box and radio_button. Before
everything was peachy…
System: OS X (10.4.10), MySQL, Ruby 1.8.5, Rails 1.2.2

This is the line that seems to offend:


<%= check_box(“tour”, “is_festival”) %>Ist ein Festival (der Festivalname wird
anstelle der Bands benutzt)

The object, a CalendarTour (in @tour) is an object extended from

The error report at the bottom reads as follows:

form_helper.rb:302:in value' #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/ form_helper.rb:302:into_check_box_tag’
form_helper.rb:210:in check_box' #{RAILS_ROOT}/app/views/resys/calendar/enter_tourdates.rhtml:13:in_run_rhtml_47app47views47resys47calendar47enter_tourdates46rhtml’

I can’t for the life of me find what’s wrong. I get these random
seeming errors in different FORMs…

Any ideas? Thanks a lot!

I was able to fix this same problem by replacing my boot.rb and
environment.rb files in my old 1.1.6 app with the same files from a
freshly-generated 1.2.3 app. Still not sure what specifically caused
it, but I suspect it’s something with the gem code in the boot.rb

Seems like that took care of it. Very strange indeed. But thanks a

Ooops, I was too fast there…
Went from lighttpd to mongrel…
Now Rails tells me (via NoMethodError) that my “Artist” class has lost
the method “quoted_id” which is derived from ActiveRecords as far as I
can see…
BUT: The funny thing is: If I call that one page (a FORM post) right
after I restarted mongrel, it works. If I enter the data into the form
again and then post the form, boom, the NoMethodError strikes. This is
driving me nuts…

Tried changing the environment.rb / boot.rb again, was no use…

Any ideas anyone?