Nokogiri installation problem on Mac 10.6.0

Hi,

I getting problem when install Nokogiri on mac snow leopard.

I get following errors :

ERROR: Error installing nokogiri:
ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
extconf.rb
mkmf.rb can’t find header files for ruby at
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ruby.h

Gem files will remain installed in
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.3.1 for inspection.
Results logged to
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.3.1/ext/nokogiri/gem_make.out

Reply as soon as possible,

Thanks,
Priyank S.

I already install libxml2 libxslt so that is not the issue so let me
know if any another reason for that.

Look in
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.3.1/ext/nokogiri/gem_make.out
like it told you and see what it says there.

On Aug 3, 8:36 am, Priyank S. [email protected] wrote:

extconf.rb
mkmf.rb can’t find header files for ruby at
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ruby.h

Gem files will remain installed in
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.3.1 for inspection.
Results logged to
/Library/Ruby/Gems/1.8/gems/nokogiri-1.4.3.1/ext/nokogiri/gem_make.out

Reply as soon as possible,

Do you have Xcode installed?

Please report an issue to Nokogiri Issue tracker (search first):

http://github.com/tenderlove/nokogiri/issues

Please include the contents of gem_make.out and more details about
your environment so developers can help you with the issue.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs