Nokogiri 1.6.3.rc3 Released

nokogiri version 1.6.3.rc3 has been released!

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri’s
many features is the ability to search documents via XPath or CSS3
selectors.

Changes:

==== Features

  • Added Node#document? and Node#processing_instruction?

==== Bug fixes

  • [JRuby] Fix Ruby memory exhaustion vulnerability. #1087 (Thanks,
    @ocher)
  • [MRI] Fix segfault during GC when using libxml-ruby and nokogiri
    together in multi-threaded environment. #895 (Thanks, @ender672!)
  • Building on OSX 10.9 stock ruby 2.0.0 now works. #1101 (Thanks,
    @zenspider!)
  • Node#parse now works again for HTML document nodes (broken in 1.6.2+).
  • Processing instructions can now be added via Node#add_next_sibling.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs