No Tx output from any daughterboards

This is primarily aimed at Josh, but I’ll take advice from
anyone. :slight_smile:

I’ve been using GnuRadio and GRC for about 9 months, and
built several successful receiver projects.

Recently, I’ve tried my first transmitter project and run into
a snag. According to our hardware spectrum analyzer, I’m not
getting any RF output. I’ve tried using a Basic-Tx, an LFTX,
an RFX-900, and an RFX-2400. The Basic and the LFTX put out
nothing, and the two RFX boards put out a feeble carrier at
about -80dbm. This is so weak that the LO leakage swamps
it (we read that at about -60dbm, 4 MHz above of the carrier).

I even tried a different USRP motherboard and TX daughterboard
that were borrowed from another project and known to be working,
with the same results. So I’m pretty sure it’s not a HW problem.

And I can’t believe there would be such a fundamental flaw in
the GRC/GnuRadio combination, so I’ve got to believe it’s a
configuration problem. I must be missing something really stupid!

Here’s my setup information:

GnuRadio 3.1.1 (release version)
GRC 0.69 (release version)
USRP Rev 4.5
Mac OSX 10.4.11 (Intel Core2-Duo)

When I setup the TX daughterboards in GRC, here’s the
parameters I use:

Basic-TX or LFTX:
Unit: 0
Side: Side B
Freq: 30000000
Interp: 20
Gain: 0
Mux: 0x0 (0 causes automatic calculation)
Auto T/R: Ignore (only used on Flex dboards)
TX Enab: Ignore (only used on Flex dboards)

RFX-900:
Unit: 0
Side: Side A
Freq: 1000000000
Interp: 20
Gain: 0
Mux: 0x0 (0 causes automatic calculation)
Auto T/R: Ignore
TX Enab: Enable

RFX-2400
Unit: 0
Side: Side A
Freq: 2400000000
Interp: 20
Gain: 0
Mux: 0x0 (0 causes automatic calculation)
Auto T/R: Ignore
TX Enab: Enable

What am I missing???

@(^.^)@ Ed

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs