No such file to load -- openssl (RuntimeError)


#1

Hi.

I have been trying all day to set up RoR; I got Ruby, Rails, Rubygems.
Everything is installed (they all react to --version). However, when I
try to run the webserver, I get the following message (terminal output
below).

I have googled this error and found hundreds of webpages. None were of
any help though. People were told to get libopenssl-ruby, among other
packets, but I have all of the packets mentioned in the posts I found.
Yet, it still fails to work… I woke up this morning with a lot of
enthusiasm to get this working, but after errors and more errors, it’s
getting pretty demotivational. Hopefully some friendly person here can
help me out!

:~/webcontent/ruby/mynewapp$ ruby script/server
=> Booting Mongrel
=> Rails 2.3.2 application starting on http://0.0.0.0:3000
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:269:in
require_frameworks': no such file to load -- openssl (RuntimeError) from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:134:inprocess’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:113:in
send' from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:113:inrun’
from /home/joris/webcontent/ruby/mynewapp/config/environment.rb:9
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:innew_constants_in’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
require' from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/commands/server.rb:84 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require’
from script/server:3


#2

I have exactly the same problem :S

I’d like to add that this is running a Ubuntu 9.04, sw versions: ruby
1.8.7, Rails 2.3.2

*** LOCAL GEMS ***

actionmailer (2.3.2)
actionpack (2.3.2)
activerecord (2.3.2)
activeresource (2.3.2)
activesupport (2.3.2)
rails (2.3.2)
rake (0.8.6)

Something else? Sb, any idea?? Please!

Cheers,
Sebas.


#3

I have the same set up and I am experiencing the same problem as sebas.

Any help would greatly be appreciated.


#4

Please try on Centos and RHEL base server.

yum install openssl

and on windows i have not much idea but try to install bin of openssl.

Thanks-
Shrii

Lukas Beaton wrote:

I have the same set up and I am experiencing the same problem as sebas.

Any help would greatly be appreciated.


#5

Shrikant L. wrote:

Please try on Centos and RHEL base server.

yum install openssl

and on windows i have not much idea but try to install bin of openssl.

Thanks-
Shrii

Lukas Beaton wrote:

I have the same set up and I am experiencing the same problem as sebas.

Any help would greatly be appreciated.

Hi all, the answer to your woes is to install libopenssl-ruby1.8

This assumes you’re using ruby version 1.8 of course

on deb systems do the following

$sudo apt-get install libopenssl1.8

Just for good measure I also install libruby1.8-extras

Hope this helps

Cheers

Peter Mac