No such file to load -- linguistics.rb

hi
i want to convert no to words so using linguistics.rb;
while using it linguistics.rb
i am receiving an error

no such file to load – linguistics.rb

i have installed gem for it
linguistics <1.0.8>

code=>
require ‘linguistics.rb’
Linguistics::use( :en )

any fix?

On Feb 12, 12:08 am, Saboor [email protected] wrote:

code=>
require ‘linguistics.rb’

Require statements do not use the .rb extension - try that.

–Matt J.

On Fri, Feb 12, 2010 at 12:08 AM, Saboor [email protected]
wrote:

code=>
require ‘linguistics.rb’
Linguistics::use( :en )

any fix?

Unless you are using Ruby 1.9 you need to require ‘rubygems’ in order
to load gems.

You can do this either in the code itself or via a command line argument
to ruby

$ ruby -e’require “rubygems”;p require “linguistics.rb”’
-e:1:in `require’: no such file to load – linguistics.rb (LoadError)
from -e:1

$ruby -rubygems -e’p require “linguistics.rb”’
true

$ruby -e’require “rubygems”;p require “linguistics.rb”’
true


Rick DeNatale

Blog: http://talklikeaduck.denhaven2.com/
Twitter: http://twitter.com/RickDeNatale
WWR: http://www.workingwithrails.com/person/9021-rick-denatale
LinkedIn: http://www.linkedin.com/in/rickdenatale

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs