No such file to load -- builder error


#1

Hi. I’m a neophyte where Ruby is concerned. I’ve installed it along
with the Rally Rest API, which integrates subversion check-ins with
the Rally Agile tool. The error in question occurs when I run the post-
commit bat file that’s part of the integration (I’m using a Windows
box).

Below is a copy of what shows up in the command-line window. Don’t
know if the problem is cuz require is being called recursively or
what. Looks like the build file (rest_builder.rb) for the API in
question is run. If so, what builder file is the error referring to?

Any ideas for a resolution would really be appreciated. Peace.

C:\RallyIntegrations\Svn2Rally>“C:\ruby\bin\ruby.exe” C:
\RallyIntegrations\Svn2Rally\svn2rally.rb

C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- builder (LoadError) from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inrequire’
from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/
rally_rest_api/rest_builder.rb:
5
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inrequire’
from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/
rally_rest_api/rest_object.rb:2

    from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:

27:in gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inrequire’
from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/
rally_rest_api/attribute_defini
tion.rb:1
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inrequire’
from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/
rally_rest_api.rb:1
from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/
rally_rest_api.rb:1:in each' from C:/ruby/lib/ruby/gems/1.8/gems/rally_rest_api-0.8.0/lib/ rally_rest_api.rb:1 from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 32:ingem_original_require’
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
32:in `require’
from C:/RallyIntegrations/Svn2Rally/svn2rally.rb:33

Steve


#2

On Dec 30, 2008, at 11:40 , delraysteve wrote:

Any ideas for a resolution would really be appreciated. Peace.

gem install builder


#3

On Dec 30, 1:50 pm, Ryan D. removed_email_address@domain.invalid wrote:

On Dec 30, 2008, at 11:40 , delraysteve wrote:

Any ideas for a resolution would really be appreciated. Peace.

gem install builder

So, it turns out from reading the Rally discussion for this that Ruby
and the Rally Rest API need to be installed on the server that’s
running svn.
Pity they didn’t say that in the release notes. We have a third party
shop running svn for us, so this integration isn’t something we can
do.
Thanks anyway.

Steve