No such file to load — ubygems (LoadError)

All of a sudden, i’m getting this error when trying to launch the
console -

no such file to load — ubygems (LoadError)

I’m using 1.2.3 as my base rails install and i also get the same problem
in a project frozen to 1.1.6. I saw a blog post at
http://wharsojo.wordpress.com/2007/05/1 … loaderror/
which recommended removing the RUBYOPT variable from my (windows)
environment. On doing this, closing the console, restarting it and
trying again, i instead get this error -

sh: /cygdrive/c/cygwin/bin/irb: /usr/bin/ruby: bad interpreter: No such
file or directory

has anyone else seen this and know how to fix it?

thanks!
max

I would grep your rails directory for ‘ubygems’. It looks like
rubygems was misspelled somewhere.

-Bill

If you remove the windows ruby.exe from your PATH, it will work in
cygwin.

On Dec 13, 4:26 pm, Max W. [email protected]

marchi wrote:

If you remove the windows ruby.exe from your PATH, it will work in
cygwin.

On Dec 13, 4:26 pm, Max W. [email protected]

ah…thanks. I’ll have to reinstall cygwin - i found out it was to do
with cygwin and deleted cygwin entirely (which i couldn’t get working
anyway). I hate the windows command line though (it’s so broken) so
i’ll reinstall cygwin and do as you suggest.

cheers!
max

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs