No Source in GRC after installing rtl-sdr and gr-osmosdr

Hey, I just tried to setup Gnuradio (3.7.5) with my RTL2832U DVB-T
dongle.

  1. First I installed Gnuradio via “sudo zypper install gnuradio”.
    Gnuradio-Companion starts and everything seems to work fine.

  2. Then I installed the rtl-sdr driver as described on Osmocom’s
    Website. “rtl_test -t” works as well.

  3. Finally I installed gr-osmosdr and opened Gnuradio-Companion but
    there is no Source field where I can select my RTL2832 dongle…

So does anyone know what I did wrong? Is it because of my operation
system: the new OpenSuse 13.2? Or is there an error in the cmake process
of gr-osmosdr (I put the output at the end of the post)?

It would be great if someone could help me.
Thanks!
Marius

cmake output:

[email protected]:~/Downloads/gr-osmosdr/build> cmake …/
– The CXX compiler identification is GNU 4.8.3
– The C compiler identification is GNU 4.8.3
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Build type not specified: defaulting to release.
– Found Git: /usr/bin/git (found version “2.1.2”)
– Extracting version information from git describe…
– Configuring Boost C++ Libraries…
– Boost version: 1.54.0
– Found the following Boost libraries:
– thread
– system
– Found PkgConfig: /usr/bin/pkg-config (found version “0.28”)
Checking for GNU Radio Module: RUNTIME
– checking for module ‘gnuradio-runtime’
– found gnuradio-runtime, version 3.7.6git

  • INCLUDES=/usr/local/include

LIBS=/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
– Found GNURADIO_RUNTIME:
/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
GNURADIO_RUNTIME_FOUND = TRUE
Checking for GNU Radio Module: BLOCKS
– checking for module ‘gnuradio-blocks’
– found gnuradio-blocks, version 3.7.6git

  • INCLUDES=/usr/local/include

LIBS=/usr/local/lib/libgnuradio-blocks.so;/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
– Found GNURADIO_BLOCKS:
/usr/local/lib/libgnuradio-blocks.so;/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
GNURADIO_BLOCKS_FOUND = TRUE
Checking for GNU Radio Module: PMT
– checking for module ‘gnuradio-runtime’
– found gnuradio-runtime, version 3.7.6git

  • INCLUDES=/usr/local/include

LIBS=/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
– Found GNURADIO_PMT:
/usr/local/lib/libgnuradio-runtime.so;/usr/local/lib/libgnuradio-pmt.so
GNURADIO_PMT_FOUND = TRUE
– checking for module ‘gnuradio-iqbalance’
– package ‘gnuradio-iqbalance’ not found
– Could NOT find GNURADIO_IQBALANCE (missing:
GNURADIO_IQBALANCE_LIBRARIES GNURADIO_IQBALANCE_INCLUDE_DIRS)
– checking for module ‘uhd’
– package ‘uhd’ not found
– checking for module ‘gnuradio-uhd’
– found gnuradio-uhd, version 3.7.5
– Found gnuradio-uhd: /usr/include, /usr/lib64/libgnuradio-uhd.so
– Found GNURADIO_UHD: /usr/lib64/libgnuradio-uhd.so
– checking for module ‘gnuradio-fcd’
– found gnuradio-fcd, version 3.7.6git
– Found gnuradio-fcd: /usr/local/include,
/usr/local/lib/libgnuradio-fcd.so
– Found GNURADIO_FCD: /usr/local/lib/libgnuradio-fcd.so
– checking for module ‘gnuradio-fcdproplus’
– package ‘gnuradio-fcdproplus’ not found
– gnuradio-fcdproplus not found.
– Could NOT find GNURADIO_FCDPP (missing: GNURADIO_FCDPP_LIBRARIES
GNURADIO_FCDPP_INCLUDE_DIRS)
– checking for module ‘libosmosdr’
– package ‘libosmosdr’ not found
– libosmosdr not found.
– checking for module ‘librtlsdr’
– found librtlsdr, version v0.5.3-6-gd447
– Found librtlsdr: /usr/local/include, /usr/local/lib/librtlsdr.so
– checking for module ‘libmirisdr’
– package ‘libmirisdr’ not found
– libmirisdr not found.
– checking for module ‘libhackrf’
– package ‘libhackrf’ not found
– Could NOT find LIBHACKRF (missing: LIBHACKRF_LIBRARIES
LIBHACKRF_INCLUDE_DIRS)
– checking for module ‘libairspy’
– package ‘libairspy’ not found
– Could NOT find LIBAIRSPY (missing: LIBAIRSPY_LIBRARIES
LIBAIRSPY_INCLUDE_DIRS)
– checking for module ‘libbladeRF’
– package ‘libbladeRF’ not found
– libbladeRF not found.
– Found Doxygen: /usr/bin/doxygen (found version “1.8.8”)
– Found PythonLibs: /usr/lib64/libpython2.7.so (found suitable version
“2.7.8”, minimum required is “2”)
– Could NOT find SWIG (missing: SWIG_EXECUTABLE SWIG_DIR)

– The build system will automatically enable all components.
– Use -DENABLE_DEFAULT=OFF to disable components by default.

– Configuring Python support support…
– Dependency PYTHONLIBS_FOUND = TRUE
– Dependency SWIG_FOUND = FALSE
– Dependency SWIG_VERSION_CHECK =
– Disabling Python support support.
– Override with -DENABLE_PYTHON=ON/OFF

– Configuring Osmocom IQ Imbalance Correction support…
– Dependency GNURADIO_IQBALANCE_FOUND = FALSE
– Disabling Osmocom IQ Imbalance Correction support.
– Override with -DENABLE_IQBALANCE=ON/OFF

– Configuring sysmocom OsmoSDR support…
– Dependency LIBOSMOSDR_FOUND = FALSE
– Disabling sysmocom OsmoSDR support.
– Override with -DENABLE_OSMOSDR=ON/OFF

– Configuring FUNcube Dongle support…
– Dependency GNURADIO_FCD_FOUND = TRUE
– Enabling FUNcube Dongle support.
– Override with -DENABLE_FCD=ON/OFF

– Configuring FUNcube Dongle Pro+ support…
– Dependency GNURADIO_FCDPP_FOUND = FALSE
– Disabling FUNcube Dongle Pro+ support.
– Override with -DENABLE_FCDPP=ON/OFF

– Configuring IQ File Source support…
– Dependency GNURADIO_BLOCKS_FOUND = TRUE
– Enabling IQ File Source support.
– Override with -DENABLE_FILE=ON/OFF

– Configuring Osmocom RTLSDR support…
– Dependency LIBRTLSDR_FOUND = TRUE
– Enabling Osmocom RTLSDR support.
– Override with -DENABLE_RTL=ON/OFF

– Configuring RTLSDR TCP Client support…
– Dependency GNURADIO_BLOCKS_FOUND = TRUE
– Enabling RTLSDR TCP Client support.
– Override with -DENABLE_RTL_TCP=ON/OFF

– Configuring Ettus USRP Devices support…
– Dependency UHD_FOUND = 0
– Dependency GNURADIO_UHD_FOUND = TRUE
– Disabling Ettus USRP Devices support.
– Override with -DENABLE_UHD=ON/OFF

– Configuring Osmocom MiriSDR support…
– Dependency LIBMIRISDR_FOUND = FALSE
– Disabling Osmocom MiriSDR support.
– Override with -DENABLE_MIRI=ON/OFF

– Configuring HackRF Jawbreaker support…
– Dependency LIBHACKRF_FOUND = FALSE
– Disabling HackRF Jawbreaker support.
– Override with -DENABLE_HACKRF=ON/OFF

– Configuring nuand bladeRF support…
– Dependency LIBBLADERF_FOUND = FALSE
– Disabling nuand bladeRF support.
– Override with -DENABLE_BLADERF=ON/OFF

– Configuring RFSPACE Receivers support…
– Enabling RFSPACE Receivers support.
– Override with -DENABLE_RFSPACE=ON/OFF

– Configuring AIRSPY Receiver support…
– Dependency LIBAIRSPY_FOUND = FALSE
– Disabling AIRSPY Receiver support.
– Override with -DENABLE_AIRSPY=ON/OFF

– ######################################################
– # Gnuradio enabled components
– ######################################################
– * FUNcube Dongle
– * IQ File Source
– * Osmocom RTLSDR
– * RTLSDR TCP Client
– * RFSPACE Receivers

– ######################################################
– # Gnuradio disabled components
– ######################################################
– * Python support
– * Osmocom IQ Imbalance Correction
– * sysmocom OsmoSDR
– * FUNcube Dongle Pro+
– * Ettus USRP Devices
– * Osmocom MiriSDR
– * HackRF Jawbreaker
– * nuand bladeRF
– * AIRSPY Receiver

– Building for version: v0.1.4-2-g8d9e6b58 / 0.1.5git
– Using install prefix: /usr/local
– Configuring done
– Generating done
– Build files have been written to:
/home/foxey/Downloads/gr-osmosdr/build