No response when using self-compiled FPGA code

Hi List,
I compiled the newest fpga code from the uhd-repository (u2_rev3) with
Xilinx’ ISE 12.2. I also used the newest firmware which is available
online (20100901) and also tried some other versions but the USRP2 does
not send a response to arp requests or icmp ping messages. So
uhd_usrp_probe and uhd_find_devices does not work anymore. Is there a
known issue on using self-compiled fpga binaries? Do I need any
arguments to make? I just compiled the code by running make and it
finished successfully and generated the u2_rev3.bin.

Some more informations:
Firmware starts normally and receives ethernet arp packets (debugged via
serial port -> eth_pkt_inspector becomes called when the arp package is
received).
The HW seems to be ok because the uhd images from ettus’ website work
fine for me.

Cheers,
Matthias

Solved it: I was using the wrong Makefile. Using the Makefile.udp, it
work’s fine.

Cheers,
Matthias

Am 01.09.2010 15:00, schrieb Matthias Schäfer:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs