No reaction from memcached

I’ve been following the instructions here http://nubyonrails.com/
articles/read/716 on how to get started with memcached.

Starting up ./script/console production I get at couple of deprecation
warnings:

./script/console production Loading production environment. DEPRECATION WARNING: model is deprecated and will be removed from Rails 2.0 See http://www.rubyonrails.org/deprecation for details. (called from ./script/../config/../config/../app/controllers/ application.rb:6) DEPRECATION WARNING: depend_on is deprecated and will be removed from Rails 2.0 See http://www.rubyonrails.org/deprecation for details. (called from model_without_deprecation at /usr/lib/ruby/gems/1.8/gems/ actionpack-1.13.1/lib/action_controller/deprecated_dependencies.rb:13)

ActiveRecord instances load just fine but I get no indication that any
caching is taking place. I get no output from my memcached-process,
nothing in the rails logs and nothing on the console says anything
about caching.

I guess that I have a config error somewhere or a version mismatch.

Here’s what I have at the end of environment.rb
require
‘cached_model’
CACHE = MemCache.new ‘localhost:11211’, :namespace => ‘my_rails_app’

I’ve also tried these settings with the same result:

require ‘cached_model’

memcache_options = {
:c_threshold => 10_000,
:compression => true,
:debug => false,
:namespace => ‘my_rails_app’,
:readonly => false,
:urlencode => false
}

CACHE = MemCache.new memcache_options
CACHE.servers = ‘localhost:11211’

Here’s my installed versions of the relevant gems:

rails (1.2.1,
1.1.6)
cached_model (1.3.1,
1.2.1)
memcache-client (1.2.0,
1.0.3)

I’ve done some googling but I’m at a loss about how to troubleshoot
this further.

Any ideas?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs