No puedo instalar rails - gem me pide el zlib

Hola a todos, este es mi primer intento con rails :slight_smile:

Esto es lo que esta pasando, luego de instalar rails 1.9.2…

[email protected]:~$ ruby -v
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]
[email protected]:~$ gem -v
1.3.7

asi que, como todo fue bien, intento con rails:

[email protected]:~$ gem install rails
ERROR: Loading command: install (LoadError)
no such file to load – zlib
ERROR: While executing gem … (NameError)
uninitialized constant Gem::Commands::InstallCommand

:frowning:

Estuve buscando por google, foros, etc… pero no encontre ninguna
respuesta que resuleva mi problema (instale el zlib, etc… y nada)

Gracias de antemano por su ayuda y su tiempo!
Saludos!

PD: SO: Ubuntu 10.04

Juan C. wrote:

Hola a todos, este es mi primer intento con rails :slight_smile:

Esto es lo que esta pasando, luego de instalar rails 1.9.2…

[email protected]:~$ ruby -v
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]
[email protected]:~$ gem -v
1.3.7

asi que, como todo fue bien, intento con rails:

Problema resuelto. Mi error es que luego de instalar la librería. no
volvia a hacer una compilacion nueva de los sources.
Gracias!,

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs