No packet reception in higher modulation

Hello,

I am running my codes in basic TX/RX with gnuradio-3.3.0 image. I am
using
benchmark_tx and benchmark_rx codes in the
gnuradio-examples/python/digital
folder to find packet loss for different modulation schemes (I believe
that
these files have been transferred to the gr-digital/examples/narrowband
folder in the new image). When I run my the benchmark codes with dbpsk
and
dqpsk modulation, the receiver receives packets. However, when I run the
codes with d8psk modulation scheme, the receiver just sits idle waiting
for
the packets but does not receive anything !

I am giving the following commands in the benchmark programs:

./benchmark_tx.py -f 2.4G -r 1M -e eth2 -m d8psk --tx-ampl 0.5

./benchmark_rx.py -f 2.4G -r 1M -e eth2 -m d8psk

I am getting the following packet reception ratios for different
modulation
schemes:

dbpsk: 99%, dqpsk: 92%, d8psk: 0% !!

I expected to get less packets (higher packet loss) through d8psk
modulation
since it is transmitting at a higher data rate. But the receiver is not
receiving anything at all !!

Your feedback will be highly appreciated.

Thanks,

Nazmul


Muhammad Nazmul I.

Graduate Student
Electrical & Computer Engineering
Wireless Information & Networking Laboratory
Rutgers, USA.

On 10/25/2011 01:48 PM, Nazmul I. wrote:

I expected to get less packets (higher packet loss) through d8psk modulation
since it is transmitting at a higher data rate. But the receiver is not
receiving anything at all !!

Your feedback will be highly appreciated.

Have you observed frequency offset?

http://gnuradio.org/redmine/projects/gnuradio/wiki/FAQ#I-have-two-USRPs-and-when-I-transmit-on-one-and-receive-on-the-other-at-the-same-frequency-I-get-an-offset

-Josh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs