No nice Permalinks with Wordpress

Hello,

after days of testing i don’t find a way to use short permalinks with
Wordpress, i can only configure URLS with /index.php/xxx in it, not sure
why.

The rewrite-rules are there, but wordpress ignores them.

I tried
try_files $uri $uri/ /index.php?$args;
and
try_files $uri $uri/ /index.php?q=$request_uri;
(both inside location / {}

If i try /xxx/ instead of /index.php/xxx/ i only see an “Nothing found
for xxx” error from wordpress.

Is there any way to fix this? I found many faqs but i don’t find my
problem :frowning:

Thanks

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,218771,218771#msg-218771

On Wed, Nov 23, 2011 at 11:31 AM, Salem [email protected] wrote:

Hello,

after days of testing i don’t find a way to use short permalinks with
Wordpress, i can only configure URLS with /index.php/xxx in it, not sure
why.

Use “Custom Structure” and remove the index.php/ part.

For the try_files, use this:

try_files $uri $uri/ /index.php?q=$uri&$args;


O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

http://wordpress.org/extend/plugins/nginx-compatibility/
You need this plugin, as WP disables permalinks when there is no
Apache’s mod_rewrite.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,218771,218817#msg-218817

On Wed, Nov 23, 2011 at 8:18 PM, Sylvia [email protected] wrote:

http://wordpress.org/extend/plugins/nginx-compatibility/
You need this plugin, as WP disables permalinks when there is no
Apache’s mod_rewrite.

It is not disabled, just not given as default choices. It’s still
possible using custom structure and removing the index.php/ part.


O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs