No more mongrel on leopard!

Hi! I’ve got a problem: just changed my mac, now I run leopard. Just
updated original gems to rails 2.0.2 and cleaned up each of them. But,
when I run script/server, there’s no more mongrel. It starts up webrick!
I want mongrel, since it’s better for debug.

How can I substitute it? Below is a sudo gem list:

actionmailer (2.0.2)
actionpack (2.0.2)
actionwebservice (1.2.6)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)
dnssd (0.6.0)
fcgi (0.8.7)
gem_plugin (0.2.3)
hpricot (0.6)
libxml-ruby (0.3.8.4)
mongrel (1.1.4)
needle (1.3.0)
net-sftp (1.1.1)
net-ssh (1.1.2)
rails (2.0.2)
rake (0.8.1)
RedCloth (3.0.4)
ruby-openid (2.0.4)
ruby-yadis (0.3.4)
rubygems-update (1.1.0)
rubynode (0.1.3)
sources (0.0.1)
sqlite3-ruby (1.2.1)
termios (0.9.4)

Why not run “mongrel_rails start”?

Ok, I’ve done it, but it tell me this:

report_activate_error': Could not find RubyGem daemons (>= 1.0.3) (Gem::LoadError) from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:311:inactivate’
from
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:337:in
activate' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:336:ineach’
from
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:336:in
activate' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:65:inactive_gem_with_options’
from
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:50:in
`gem’
from /usr/bin/mongrel_rails:18

:frowning:

Diwa del Mundo wrote:

Why not run “mongrel_rails start”?

Hey,

Try installing the daemons gem:

sudo gem install daemons

Ok, thank you! I needed to install fastthread and cgi_multipart_eof_fix
as well.

Now I don’t even need anymore to do ‘mongrel_rails start’: mongrel start
soon on script/server! :slight_smile:

Thank you a lot!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs