No input file specified

Hi,

I deploy the application using Capistrano to /var/nginx/www/myapp. The
current code is always at /var/nginx/www/myapp/current.

So I changes the server’s root folder to /var/nginx/www/myapp/current
hoping that the location specs would be raktive to this folder. Since
then I get the “No input file specified.” error.

I also have fastcgi_param SCRIPT_FILENAME
$document_root$fastcgi_script_name;

What might be wrong?

Thanks,
Yash

Are you using Capistrano with PHP?
No input file specified usually if there is no running PHP there.

Regards,
Joe

When I access http://localhost:82/index.php
I get “No input file specified.”

I have php running using:
php-cgi -b 127.0.0.1:9000

My conf file is:
server {
listen 82 default;
## SSL directives might go here

server_name localhost 127.0.0.1 *;

    root /cygdrive/e/xampp/htdocs/getit/src/myapp;
error_log /cygdrive/e/nginx.error.log notice;
access_log /cygdrive/e/nginx.access.log ;

rewrite_log on;

    location / {
        index index.html index.php; ## Allow a static html file to

be shown first
try_files $uri $uri/ @magehandler; ## If missing pass the
URI to Magento’s front handler
}

    ## These locations would be hidden by .htaccess normally
    location ^~ /app/                { deny all; }
    location ^~ /includes/           { deny all; }
    location ^~ /lib/                { deny all; }
    location ^~ /media/downloadable/ { deny all; }
    location ^~ /pkginfo/            { deny all; }
    location ^~ /report/config.xml   { deny all; }
    location ^~ /var/                { deny all; }

    location ^~  /. { ## Disable .htaccess and other hidden files
        return 404;
    }

#Any request that does not match the regex locations below is sent

here
location @handler { ## Magento uses a common front handler

        rewrite / /index.php$1 last;
    }
    location @magehandler { ## Magento uses a common front handler

        rewrite (.*) /index.php$1 last;
    }

#The more-specific regex are at the top.
#The regex's are evaluated in the order in which they appear.
    location ~ .php.*$ { ## Execute PHP scripts

     proxy_read_timeout 120;
  proxy_connect_timeout 120;
        expires        off; ## Do not cache dynamic content
        fastcgi_pass   127.0.0.1:9000;
        #fastcgi_param  HTTPS $fastcgi_https;

  fastcgi_param  SCRIPT_FILENAME 

$document_root$fastcgi_script_name;
fastcgi_param MAGE_RUN_CODE default; ## Store code is
defined in administration > Configuration > Manage Stores
fastcgi_param MAGE_RUN_TYPE store;
include fastcgi_params; ## See
/etc/nginx/fastcgi_params
}
location ~ /(media|skin|js)/ { }
location ~ /(tag|admin|customer|wishlist|checkout|catalog|app).$ {
#store URL
rewrite /(.
)$ /index.php/$1 last;
}
location ~ /[a-zA-Z]+$ { #store URL
rewrite ^/([a-zA-Z]+) ?store=$1 last;
}
location ~ /[a-zA-Z]+/ { #store URL
rewrite ^/([a-zA-Z]+)(.*) $2?store=$1 last;
}
}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,229066,229086#msg-229086

On Mon, Jul 30, 2012 at 01:46:19AM -0400, yashgt wrote:

Hi there,

When I access http://localhost:82/index.php
I get “No input file specified.”

That message (usually) comes from the fastcgi server, and (usually)
means that the SCRIPT_FILENAME that was sent was not found by that
server.

From your configuration, it looks like that for this request,
SCRIPT_FILENAME is
/cygdrive/e/xampp/htdocs/getit/src/myapp/index.php .

Does that filename exist, from the point of view of the fastcgi server?

(The “/cygdrive/” bit suggests that cygwin is involved somehow. Is
php running under cygwin? Does it have the same view of the filesystem
as nginx?)

f

Francis D. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs