No input file specified

if fastcgi is running I get “No input file spcified.”
if the fastcgi is not up, I get “The page you are looking for is
temporarily unavailable.”
This is my config file:

server {
listen 80;
server_name website.org;

root   /home/user/public_html;

location / {
index index.php index.html index.htm;
}
location ~ .php$ {
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
/home/user/public_html$fastcgi_script_name;
include /usr/local/nginx/conf/fastcgi_params;

}
error_page 500 502 503 504 /50x.html;
location = /home/user/public_html/50x.html {
root html;
}
}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,15713,15713#msg-15713

On Thu, Oct 22, 2009 at 6:04 AM, tw1sted [email protected] wrote:

    location / {
    location = /home/user/public_html/50x.html {
      root  html;
    }
}

check permission of the php files

I did permissions seem fine, my php test file is 0644

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,15713,15806#msg-15806

On Thu, Oct 22, 2009 at 4:36 PM, tw1sted [email protected] wrote:

I did permissions seem fine, my php test file is 0644

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,15713,15806#msg-15806

how about the directories’? is static files served/displayed properly?
your config looks fine.

‘No input file specified’, from my experience, is caused by either
wrong target path or permission.

edogawaconan Wrote:

www.asciiribbon.org
Yes it is, index.html displays fine.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,15713,15835#msg-15835

tw1sted wrote:

edogawaconan Wrote:

www.asciiribbon.org
Yes it is, index.html displays fine.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,15713,15835#msg-15835

You can try this:
1.create a file named php.conf in you nginx conf directory,
and write this:

fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx;

fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;

fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;

PHP only, required if PHP was built with --enable-force-cgi-redirect

fastcgi_param REDIRECT_STATUS 200;

  1. change your nginx config file to this:
    server {
    listen 80;
    server_name website.org;

root /home/user/public_html;
index index.php index.html index.htm;

location ~ .php$ {
include php.conf;
}
error_page 500 502 503 504 /50x.html;
location = /home/user/public_html/50x.html {
root html;
}
}

On Fri, Oct 23, 2009 at 4:50 PM, tw1sted [email protected] wrote:

Still same "No input file specified. " error.

what’s your OS, php and nginx version?

are you starting php chrooted?

Yu Sun Wrote:

fastcgi_pass 127.0.0.1:9000;
$document_root$fastcgi_script_name;
fastcgi_param SERVER_ADDR $server_addr;
server {
error_page 500 502 503 504 /50x.html;
location = /home/user/public_html/50x.html {
root html;
}
}


Posted via http://www.ruby-forum.com/.

Still same "No input file specified. " error.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,15713,16188#msg-16188

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs