No error but mail not sent?


#1

Hello everyone!

In the console, it says “Email sent” with all informations. But when I
check my inbox I got nothing.

Any help?

Thank you!


#2

No I’m in local so I use localhost. Am I wrong?


#3

Get Rails out of the equation. Can you have your local smtp server
send out emails directly, without using Rails?

On Mar 9, 4:50 pm, Guillaume L. removed_email_address@domain.invalid


#4

Check your spam folder?

Do you have a SMTP server running?

Robby

On Mon, Mar 9, 2009 at 12:14 PM, Guillaume L.
removed_email_address@domain.invalid wrote:


Posted via http://www.ruby-forum.com/.


Robby R.
Chief Evangelist, Partner

PLANET ARGON, LLC
design // development // hosting w/Ruby on Rails

http://planetargon.com/
http://robbyonrails.com/
http://twitter.com/planetargon
aim: planetargon

+1 503 445 2457
+1 877 55 ARGON [toll free]
+1 815 642 4068 [fax]


#5

I don’t know? How can I try?


#6

Without knowing what your SMTP server is, not much we can do. One
generic
way is with telnet. A search for “telnet smtp send email” gives you this
post:

http://blogs.crsw.com/mark/archive/2006/07/06/2032.aspx

Also, try locating the mail server’s logs and see if that points you on
the
right direction.

Hope that helps,
-Harold

On Mon, Mar 9, 2009 at 5:13 PM, Guillaume L. <


#7

Are you running in Development mode? ActionMailer defaults to not
raising errors in Development mode. Edit this line in your config/
environments/development.rb file (If the line doesn’t exist, add it)

config.action_mailer.raise_delivery_errors = true

This will at least trigger an error, which can help you identify the
root cause.

On Mar 9, 12:14 pm, Guillaume L. <rails-mailing-l…@andreas-