No Connection Thru http://localhost:3000

Hello,

I’m new to ROR so I’m hoping I’ve found the right forum. My problem is
that when I set up my ROR environment and direct my browser to
http://localhost:3000, I get the following page:

[Replace this File!

This is the default index.html file being served out of the www
directory.

You should replace this with something more appropriate.]

Dell Precision Workstation 670
Windows XP Pro 5.1.2600 Service Pack 2 Build 2600
InstantRails (installed at C:\InstantRails)
RubyGems 1.0.1 (wasn’t sure if included in IRails so installed via “ruby
setup.rb” prompt and ran successfully)

When I test the mongrel development and production servers (0.0.0.0:3001
and 0.0.0.0:3002),they are working fine.

-I’ve tried restarting the servers
-verified the http.conf file is for port listening for localhost at 3000

I’m not quite sure what to do next to resolve this issue. I would
appreciate any help offered or a point in the right direction.

Delete the file, and point one of your routes to
your starting controller. Maybe your login/account signup?

On Dec 28, 2007, at 5:44 PM, Calvin Howard wrote:

directory.

You should replace this with something more appropriate.]

Each new rails project includes an index.html in the public
directory. You need to remove it or replace it. If you are going to
redirect / to one of your routes (almost guaranteed), you need to
delete it. If not, just replace it with something more appropriate
for your project.

Peace,
Phillip

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs