No audio on os x reading .dat files

Hi everyone,
I have successfully installed gnu-radio from cvs following the
install instructions from Jon Jacky:
http://staff.washington.edu/~jon/gr-osx/gr-osx-prereq.html
I am on OS X Tiger, 1.33 GHz iBook G4. I am using the gr-audio-osx. I
do not have any hardware, but the usrp and gr-usrp are correctly
installed. I can run the audio examples with no problem, but when I
try the examples to listen to a .dat file, I get nothing, although my
cpu shows it is working.

This is actually the second time around. I had installed everything
good with the tarballs and just getting and making the necessary
baseline software. With the tarballs, only portaudio would work with
the audio example files, and only based on the portaudio2 version
996, taken from a discussion recommendation. The audio-osx didn’t
seem to work. But again, the audio-portaudio was working with the
audio example files, i.e. monotone and dial_tone etc.
With both versions of the above I tried
./wfm_rcv_file.py wfm_256k_complex_baseband.dat
and I hear nothing. My cpu is working though. I also tried the
samples from
http://www.kd7lmo.net/ground_gnuradio_ota.html
and the software offered there and ran them exactly as shown there,
and still the same response. The programs start, act as if they are
working, but no sound, cpu is working.
Any ideas? I have a feeling my computer can’t handle the
computations, but I am not sure…
Also, which scripts can I use read sample .dat files into the wxgui?
I would like to know if my computer can even read and compute the
data and show it correctly.

If I can get this running, I would like to get the usrp hardware. But
I want to be sure that it works first on my ibook before I invest the
money.
Thanks before hand. By the way, I admire the work that everyone has
put into this project. It is really inspiring!

Sincerely,
Josh

Josh - I’m downloading one of the .dat files from kd7lmo, but that’s
sort of slow :wink:

In the mean time, let’s get a bit of background on your setup. Which
Mac hardware & OS version?

Any reasonably modern Mac should be able to deal OK with the filters
and audio involved. That’s all done in single-precision floating
point (“float”).

The .dat format is complex, meaning 2 floats per item (one
“real” or “in phase”, and the other “imaginary” or “in quadrature”).

Given that PortAudio can handle the audio, gr-audio-osx should be
able to as well. But it doesn’t work for me either (the file
finished downloading) … so clearly there’s something odd going on.
I will investigate this over the coming weekend, and will get this
issue resolved as quickly as I can put time into it … got lots on
my plate already.

As for “getting this running”, we will certainly get .dat files
running on gr-audio-osx, just be patient. It might take a few
iterations and a couple of weeks to sort this out; really depends on
the issue. - MLD

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs