NGINX w/ virtual hosts and FasstCGI

Hi!

I have a virtual host that is a wordpress blog, and a second that serves
static files. When the second one is active, FastCGI refuses to render
any of the PHP files on the wordpress blog. I am using nginx 0.6.32
w/php-fpm on FreeBSD 7. Here is my nginx.conf and fastcgi_params

worker_processes 1;

#pid logs/nginx.pid;

events {
worker_connections 1024;
use kqueue;
}

http {
include mime.types;
default_type application/octet-stream;
server_names_hash_bucket_size 128;

sendfile        on;

keepalive_timeout  65;


server {
    listen       80;
    server_name  ****;

autoindex on;

    location / {
        root   /usr/local/www/nginx;
        index  index.html index.htm index.php;
    }


    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /usr/local/www/nginx-dist;
    }

}
server {
listen 80;
server_name ****;
autoindex on;

   location / {
        root   /usr/local/www/tvox;
        index  index.html index.htm index.php;
    }

    location ~ \.php$ {
        root           html;
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME

/usr/local/www/nginx$fastcgi_script_name;
include fastcgi_params;
}

}

}


fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;

fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;

fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx/$nginx_version;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $host;

PHP only, required if PHP was built with --enable-force-cgi-redirect

fastcgi_param REDIRECT_STATUS 200;

{

        root           html;
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME

/usr/local/www/nginx$fastcgi_script_name;
include fastcgi_params;

Nevermind, fixed it. I needed to move the fastcgi part in nginx.conf to
the first server. Stupid error.

...

http {

fastcgi_intercept_errors on;
fastcgi_index index.php;
include fastcgi.conf;

...

server {
listen 80;
server_name ****;
autoindex on;
root /usr/local/www/nginx;
index index.html index.htm index.php;
error_page 500 502 503 504 /50x.html;

location = /50x.html {
root /usr/local/www/nginx-dist;}}

server {
listen 80;
server_name ****;
autoindex on;
root /usr/local/www/tvox;
index index.html index.htm index.php;

    location ~ \.php$ {
        fastcgi_pass   127.0.0.1:9000;}

...

####################

koko:/usr/local/nginx/conf# cat fastcgi.conf

fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param DOCUMENT_URI $document_uri;
fastcgi_param DOCUMENT_ROOT $document_root;
fastcgi_param SERVER_PROTOCOL $server_protocol;

fastcgi_param GATEWAY_INTERFACE CGI/1.1;
fastcgi_param SERVER_SOFTWARE nginx;

fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;
fastcgi_param REDIRECT_STATUS 200;

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs