Nginx v0.7.67 and php-fpm 5.3.3 SEO "pretty URL's" Problem

Hi, I’m having a problem with nginx after upgrading php-fpm from PHP
version 5.3.2 > 5.3.3 (internal php-fpm version 0.6.0 > 0.6.5)
After doing the upgrade a “pretty URL’s” fastcgi_pass I use no longer
works, now php-fpm does not care about the URL’s, so it is very strange
if that would be the culprit, I’ve asked the php-fpm guys without
getting anywhere, I’ve also looked for it’s changelog for versions 0.6.0

0.6.5 without luck…

This is the rewrite I use:

        ## Forum Archive fastCGI pass
        location /vb/all/ {
          rewrite ^/vb/all/windows/(.*)$ /vb/all/windows?$1 break;
          rewrite ^/vb/all /vb/all/windows/ permanent;
            fastcgi_pass  unix:/dev/shm/php.sock;
            fastcgi_param SCRIPT_FILENAME
$document_root/vb/all/windows;
            fastcgi_param QUERY_STRING    $query_string;
        }

So you see the file named “windows” without extension is my PHP file,
with php 5.3.2 this works great, you can see it live here:

But with php 5.3.3 it fails, I’m linking a log excerpt of the error
The top part is where it is working
And below that my internal testserver with the updated PHP where it is
not working…
http://pastebin.com/CqxzUqLf

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,116453,116453#msg-116453

On Wed, Aug 04, 2010 at 06:50:31AM -0400, Per Hansson wrote:

    ## Forum Archive fastCGI pass

So you see the file named “windows” without extension is my PHP file,
with php 5.3.2 this works great, you can see it live here:
http://www.techspot.com/vb/all

But with php 5.3.3 it fails, I’m linking a log excerpt of the error
The top part is where it is working
And below that my internal testserver with the updated PHP where it is
not working…
http://pastebin.com/CqxzUqLf

I have no idea why it can not work on php 5.3.3, but it’s better to
use this more clear configuration:

 location ~ ^/vb/all/windows/(.*)$ {
     fastcgi_pass  unix:/dev/shm/php.sock;
     fastcgi_param SCRIPT_FILENAME $document_root/vb/all/windows;
     fastcgi_param QUERY_STRING    $1;
 }

 location = /vb/all/ {
     rewrite ^ /vb/all/windows/ permanent;
 }


Igor S.
http://sysoev.ru/en/

Hi again, I’ve tried to figure this out best I can but failed so far :frowning:
What I find is the last thing in the access log, we have a status code
of “200” so everything is correct
However the byte size sent to the client is only 31 bytes, it should be
1740 bytes…
When I do “view source” in the client browser I see nothing, and the
page itself is just a white page

It is as if error logging was not enabled, however there is nothing in
the logs themselves, and the php.ini has all error reporting features I
could find enabled;
fastcgi.logging = 1
fastcgi.error_header = “HTTP/1.0 550 Server Made Big Boo”
error_reporting = E_ALL & ~E_DEPRECATED
display_errors = On
display_startup_errors = On
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
html_errors = On
error_log = /var/log/php.log

nginx.conf;
Posted above http://pastebin.com/wptPaLms

php-fpm.conf;
log_level = debug

php-fpm www.conf
php_admin_flag[log_errors] = on

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,116453,119883#msg-119883

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs