Nginx upload progress module - large file upload stopped

Hello,

I’ve been using the Nginx Upload Progress Module as described here:

http://wiki.codemongers.com/NginxHttpUploadProgressModule

It’s working really well. Although I just tried uploading a very large
file (nearly 1 GB which is under my client_max_body_size setting) and
after uploading almost 700 MB (which took about 4.5 hours), the upload
stopped. I checked the Nginx error log and it said the following:

2008/03/20 02:42:57 [notice] 19751#0: signal 17 (SIGCHLD) received
2008/03/20 02:42:57 [alert] 19751#0: worker process 19755 exited on
signal 11
2008/03/20 02:42:57 [notice] 19751#0: start worker process 19852
2008/03/20 02:42:57 [notice] 19751#0: signal 29 (SIGIO) received

Why would the worker process be shut down? Is there a max time limit on
requests/uploads? If so, can it be changed in the config file? Any help
or suggestions would be greatly appreciated. Thanks!

I know it may sound stupid, but did you take into account the
conversion from bits to bytes, i.e: 1MB = 1024bits? The file your
tried to upload is probably bigger than the max size allowed. That’s
what came on top of my head when reading your message.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs