Nginx Terminates at 71.6 kilobytes

Hi,

I am using the latest development version of nginx (0.8.36) on
Debian Lenny x86.

For some reason, my nginx installation is not allowing
files larger than 71.6 kilobytes to transfer. A larger file simply just
transfers the first 71.6 kilobytes and then terminates.

Any suggestions
on what I can do would be helpful.

Thank you,

Shahan

On Sun, Apr 25, 2010 at 10:08:40PM -0700, Shahan K. wrote:

I am using the latest development version of nginx (0.8.36) on
Debian Lenny x86.

For some reason, my nginx installation is not allowing
files larger than 71.6 kilobytes to transfer. A larger file simply just
transfers the first 71.6 kilobytes and then terminates.

Any suggestions
on what I can do would be helpful.

Is anything in error_log ?


Igor S.
http://sysoev.ru/en/

The error wasn’t nginx’s fault. I the temporary cache directory ran out
of space.

Thanks,

Shahan

On Sun, 25 Apr 2010 22:08:40 -0700, Shahan
Khan wrote:

Hi,

I am using the latest development version of nginx
(0.8.36) on Debian Lenny x86.

For some reason, my nginx installation is
not allowing files larger than 71.6 kilobytes to transfer. A larger file
simply just transfers the first 71.6 kilobytes and then terminates.

Any
suggestions on what I can do would be helpful.

Thank you,

Shahan

The same thing happened to me ~1 year ago, but I didn’t reported it.
When you run out of space, nginx only serves the first
proxy_buffer_size kb from the response. This was the source of
corruption of part of my images during a backup done through nginx.

IMO in this case nginx should answer with a 50x .

On Tue, Apr 27, 2010 at 3:36 AM, Shahan K. [email protected] wrote:

Shahan


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Joaquin Cuenca Abela

Maybe a nginx feature that should be added is when the temporary cache
directory runs out of space, nginx disable the proxy cache buffer and
also
disables gzip encoding.

Shahan

On Tue, 27 Apr 2010 09:11:42 +0200, Joaquin Cuenca Abela
[email protected] wrote:

space.
Lenny
x86.

For some reason, my nginx installation is not allowing files larger
than

71.6 kilobytes to transfer. A larger file simply just transfers the
first

The same thing happened to me ~1 year ago, but I didn’t reported it.
When you run out of space, nginx only serves the first
proxy_buffer_size kb from the response. This was the source of
corruption of part of my images during a backup done through nginx.

IMO in this case nginx shou

On Tue, Apr 27, 2010 at 3:36 AM, Shahan K. [email protected] wrote:

Shahan


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Joaquin Cuenca Abela

On Tue, Apr 27, 2010 at 6:47 PM, Shahan K. [email protected] wrote:

Maybe a nginx feature that should be added is when the temporary cache
directory runs out of space, nginx disable the proxy cache buffer and also
disables gzip encoding.

I personally disagree, it’s quite normal (if not expected!) for software
to
stop working upon disk fill-up, and trying to recover smartly from this
(and
then maybe a few million other issues) would make it more complex, less
mantainable and slower.

+1 for returning a 500 instead, and logging the error as critical if it
doesn’t already.

Bye

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs