Nginx + ssi + remote uri access does not work

I have a setup where my nginx is in front with apache+PHP behind.

My PHP application cache some page in memcache which are accessed by
nginx directly except some dynamic part which are build using SSI in
Nginx.

The first problem I had was nginx didnt try to use memcache for ssi URI.

So I figured that if I force it to use a full URL, it would do it.

But in logs file (both nginx and apache) I can see that a slash has been
added at the beginning of the url

http ssi filter “/http://www.example.com/myuser

In the source code of the SSI module I see a PREFIX that seems to be
added, but I can really tell if I can disable it.

Anybody got this issue? Nginx version : 0.7.62 on Ubuntu Karmic 64bits

Thanks a lot

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,74756,74756#msg-74756

Hello!

On Tue, Apr 13, 2010 at 11:34:45PM -0400, stunti wrote:

What do you mean by “didnt try to use memcache”?

So I figured that if I force it to use a full URL, it would do
it.

No, it wouldn’t. SSI only supports URI local to server in
question (i.e. path only). If you need to include some external
URL you have to configure appropriate proxy_pass. E.g.

<!--#include virtual="/example-com-myuser" -->

and in nginx.conf:

location = /example-com-myuser {
    proxy_pass http://www.example.com/myuser;
}

Maxim D.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs