Nginx, solaris, eventport

Hi.

I’m using nginx on Solaris for years. For years I’ve been experiencing
errors when eventport is on (with /dev/poll everything is fine, but I’m
kinda perfectionist and I want to use native solaris features).

I realize that screaming “help with eventport” is counter-productive, so
how
can I localize/debug my troubles to write a comprehensive error report ?
Right now the problem looks like the inability to connect to port 80
which
nginx is listening on, error log on the “notice” level is silent about
reasons of this. Restarting nginx helps. Will switching to “debug”
loglevel
clarify this or do I need to do something else ?

Thanks.
Eugene.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,240568,240568#msg-240568

On Thu, Jul 04, 2013 at 02:13:38AM -0400, drook wrote:

reasons of this. Restarting nginx helps. Will switching to “debug” loglevel
clarify this or do I need to do something else ?

Thanks.
Eugene.

http://nginx.org/en/docs/debugging_log.html
http://wiki.nginx.org/Debugging

Hello!

On Thu, Jul 04, 2013 at 02:13:38AM -0400, drook wrote:

reasons of this. Restarting nginx helps. Will switching to “debug” loglevel
clarify this or do I need to do something else ?

There are number of known problems with eventport implementation,
notably related to work with upstream servers. It needs
attention.


Maxim D.
http://nginx.org/en/donation.html

Hi.

I finally managed to catch this situation.
I have a log from nginx running the following config:

worker_processes 8;
worker_rlimit_nofile 16384;

error_log /var/log/nginx/error.log debug;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
use eventport;

}

It can be obtained from: http://music.enaza.ru/error.log.bad.gz

Around 13:36 August, 1st, log time, nginx stopped handling web-request
(I
gor timeout in browser). This situation was cleared with nginx restart.

nginx version and modules information:

nginx version: nginx/1.4.1
TLS SNI support enabled
configure arguments: --prefix=/usr/local/nginx --with-http_ssl_module
–with-debug --with-http_realip_module --with-http_xslt_module
–with-pcre=…/pcre-8.33 --with-cc-opt=-m64 --with-ld-opt=-m64
–with-http_secure_link_module --with-pcre-opt=-m64
–with-http_stub_status_module --with-poll_module --with-select_module

Thanks.
Eugene.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,240568,241434#msg-241434

I have also a cacti graph, representing the state of tcp connections for
the
period of the accident:

http://unix.zhegan.in/files/tcp_connections.png

looks like handshakes were fine, but the the exchange was stalled for
each
stream.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,240568,241466#msg-241466