Nginx segfault

I tried to upgrade my passenger+nginx install to passenger 3.0.11 on our
staging server to match our production server, I’ve also upgraded to
ruby 1.9.3. Previously I had successfully run passenger 3.0.3 with ruby

After installing the new passenger gem 9.0.11, I install as usual using
passenger-install-nginx-module. Everything seems to build without any
problems but when I try and do:

/opt/nginx/sbin/nginx -V

I get “Segmentation fault”, when I look in the log file I have:

Apr 19 19:00:28 jbdev1 kernel: nginx[32336]: segfault at 705740 ip
0000000000705740 sp 00007fff4673f478 error 15 in nginx[6f5000+11000]

I’ve tried building with the latest version of passenger 9.0.12 but I
get the same problem. I’ve installed passenger+nginx many times on many
server without this problem.

I’m running this particular build on suse linux

Linux jbdev1 #1 SMP 2009-02-28 04:40:21 +0100 x86_64
x86_64 x86_64 GNU/Linux
SUSE Linux Enterprise Server 11 (x86_64)
gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)

Any help appreciated.


Posted at Nginx Forum:

Ran gdb with a backtrace and got the following, is there an incompatible
library or something?

Program received signal SIGSEGV, Segmentation fault.
0x00000000006d2660 in strcmp@@GLIBC_2.2.5 ()
(gdb) bt full
#0 0x00000000006d2660 in strcmp@@GLIBC_2.2.5 ()
No symbol table info available.
#1 0x00007ffff7dea4a7 in _dl_relocate_object () from
No symbol table info available.
#2 0x00007fff00000001 in ?? ()
No symbol table info available.
#3 0x0000000000000000 in ?? ()
No symbol table info available.

Posted at Nginx Forum: