Nginx mss patch

hi all,
we made some changes to nginx in order to support tcp mss which is
already
supported by haproxy. you can see the attached patch for details. it is
a
patch against version 0.8.54.

the configuration is very easy.
server {
listen 80 mss=1440;
}

Hi,

Just out of curiosity, could you please provide some context, i.e. in
what
circumstance do you have to change the TCP MSS or the benefit? After
all,
there’re TCP path MTU discovery mechanisms already.

As for the patch itself, I don’t think it’s a good idea to set the
default
value of mss to 1024, since it will punish those who don’t want this
feature. BTW, the TCP_MAXSEG option is not supported by all OS vendors,
so
you should test it first (in auto/os/features).

P.S. It seems that the diff format of your patch is wrong.

Regards,
Joshua

MTU discovery mechanisms does not work very well for ADSL users with
PPPoE
link, especially when they use wireless home router. client users may
failed
to upload picture or music or any other big post requests. here is a
post
regarding to this problem.
http://hi.baidu.com/ybbmdf/blog/item/287d878b498e04d6fc1f1079.html( i am
sorry it is in Chinese). so we have to decrease the tcp package size.

BTW, thanks for your advice for the patch, its very nice.

On Thu, Jun 09, 2011 at 01:10:00PM +0800, Joshua Z. wrote:

Hi,

Just out of curiosity, could you please provide some context, i.e. in what
circumstance do you have to change the TCP MSS or the benefit? After all,
there’re TCP path MTU discovery mechanisms already.

As for the patch itself, I don’t think it’s a good idea to set the default
value of mss to 1024, since it will punish those who don’t want this
feature. BTW, the TCP_MAXSEG option is not supported by all OS vendors, so
you should test it first (in auto/os/features).

Yes, the default TCP_MAXSEG value should not be set, and
should be handled like rcvbuf or sndbuf option.


Igor S.

some wireless home router’s mtu parameter was not set up correctly, and
we
have to use this patch to indicate end users to send a smaller package.
However this feature does not function below kernel version 2.6.28.

the new mss patch. TCP_MAXSEG value is not set by default.

the previous one was generated using git diff, hopefully the format is
right
this time.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs