Nginx modifying the jsonp response message

Hi,

We are creating a web api application. In one of our API’s if there are
any
validation errors, we are returning the error message in JSONP format.
In
the API Request URL user adds a query string parameter
?jsoncallback=xxxxxxxxxx.

On validation failure we are throwing a 400 bad request JSONP with
response
message in the below format.

xxxxxxxxxx({“error”,“error message”})

It is working good in all the environments, where there is no nginx. In
our
staging environment we have nginx configured.

Here it is modifying the output as below.

badrequest{“error”,“error message”})

Because of this our front end application is unable to read the response
message.

Could you please let me know, what configuration setting of nginx could
cause this problem?

Thanks in Advance
Venkat.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,230799,230799#msg-230799

Hello!

On Mon, Sep 17, 2012 at 04:34:27PM -0400, venkat wrote:

xxxxxxxxxx({“error”,“error message”})

Could you please let me know, what configuration setting of nginx could
cause this problem?

I would suggest that this is caused by error_page 400 +
proxy_intercept_errors configured.

Maxim D.

Sorry for the above post. Actually the problem is not due to nginx.

It is due to IIS 7.5 in our staging server which is causing the problem.

Below configuration change in web.config has fixed it.

<system.webServer>

</system.webServer>

Thanks,
Venkat.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,230799,230822#msg-230822

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs