Nginx Load balancer mode for JBoss / Icefaces application

Hello
We have setup nginx as a Loadbalancer on Centos 5.2 x64. nginx is
acting as a LB for a web application developed using Java servlets and
Icefaces (1.8.2). The web application is deployed on JBoss 5.1. After
configuration nginx is able to redirect the queries to the upstream
servers properly. However the session information is not being passed
through or is being modified. So the Icefaces servlet is repeatedly
refreshing the login page every few seconds and keeps creating new
sessions.
Please advise on any additional settings that need to be made. The
current settings are:
(nginx is running on 192.168.1.137)
upstream int-lb { server 192.168.1.139:8080; server
192.168.1.138:8080;}
server { listen 80; server_name int-lb;
#charset koi8-r; access_log /var/log/nginx/host.access.log
main; error_log /var/log/nginx/host.error.log debug; root
/usr/app/jboss5/server/default/deploy/admin-console.war;
location / { proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host; proxy_set_header
X-Forwarded-For $proxy_add_x_forwarded_for; proxy_pass
http://int-lb; }}
Thanks in advance for all assistance.

Regards
Srini

However the session information is not being passed through or is being
modified.

How do you know that? I think the problem is the session is sent to be
the
wrong jboss server.

If the Jboss uses the similar session sticky way as Tomcat/Resin, you
can
use my nginx_jvm_route_module:
http://code.google.com/p/nginx-upstream-jvm-route/

2011/11/14 Srinivasan S. [email protected]

Hi
You were bang on! Thanks. That was the issue. For now i introduced
the ip_hask; key for now in the upstream section and that fixed it.
I will try your module. We want to actually also implement the
HttpUpstreamFairModule to improve the distribution. Will the sticky
session module that you linked to work in conjunction with that?
Thanks for your timely help, greatly appreciated.
Regards

Date: Tue, 15 Nov 2011 10:47:53 +0800
Subject: Re: Nginx Load balancer mode for JBoss / Icefaces application
From: [email protected]
To: [email protected]

However the session information is not being passed through or is being
modified.

How do you know that? I think the problem is the session is sent to be
the wrong jboss server.
If the Jboss uses the similar session sticky way as Tomcat/Resin, you
can use my nginx_jvm_route_module:
http://code.google.com/p/nginx-upstream-jvm-route/

2011/11/14 Srinivasan S. [email protected]

Hello
We have setup nginx as a Loadbalancer on Centos 5.2 x64. nginx is
acting as a LB for a web application developed using Java servlets and
Icefaces (1.8.2). The web application is deployed on JBoss 5.1. After
configuration nginx is able to redirect the queries to the upstream
servers properly. However the session information is not being passed
through or is being modified. So the Icefaces servlet is repeatedly
refreshing the login page every few seconds and keeps creating new
sessions.

Please advise on any additional settings that need to be made. The
current settings are:

(nginx is running on 192.168.1.137)
upstream int-lb {
server 192.168.1.139:8080; server 192.168.1.138:8080;
}
server { listen 80;
server_name int-lb;
#charset koi8-r; access_log /var/log/nginx/host.access.log
main;
error_log /var/log/nginx/host.error.log debug; root
/usr/app/jboss5/server/default/deploy/admin-console.war;

location / {        proxy_set_header X-Forwarded-Host $host; 

proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass http://int-lb;
}}
Thanks in advance for all assistance.

Regards
Srini


nginx mailing list

[email protected]

http://mailman.nginx.org/mailman/listinfo/nginx

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs