Nginx.exe has encountered a problem and needs to close. (SSL)

I have configured the server to accept SSL connections and after two or
three requests always gives the error:
nginx.exe has encountered a problem and needs to close.
Restart server does not work, the first request fails. Restart the
computer let me make two or three requests without problems and then
fails.
For port 80 works correctly.
I have tried versions 1.4.5 and 1.5.10. My operating system is Windows
XP SP3.
This is my setup:

worker_processes 1;

events {
worker_connections 1024;
}

http {
include mime.types;
charset utf-8;
default_type application/octet-stream;
gzip on;

log_format main '$remote_addr - $remote_user [$time_local] “$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;

access_log logs/access.log main;

ssl_session_cache shared:SSL:10m;
ssl_session_timeout 10m;
ssl_certificate server.crt;
ssl_certificate_key server.key;

server
{
listen 80;
listen 443 ssl;
server_name localhost
ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers HIGH:!aNULL:!MD5;

root D:\symfony\web;
location ~ [^/].php(/|$)
{
fastcgi_split_path_info ^(.+?.php)(/.*)$;
if (!-f $document_root$fastcgi_script_name)
{
return 404;
}
#WARNING ABOUT PORT: Many guides suggest setting PHP to port 9000.
The XDebug extension uses port 9000 by default.
fastcgi_pass 127.0.0.1:9123;
fastcgi_index index.php;
#fastcgi_param SCRIPT_FILENAME $request_filename;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
#fastcgi_param QUERY_STRING $query_string;
#fastcgi_read_timeout 180;
}
}
}

Felix Quintana Wrote:

I have configured the server to accept SSL connections and after two
or three requests always gives the error:
nginx.exe has encountered a problem and needs to close.
[…]
ssl_session_cache shared:SSL:10m;

This is a known issue, ssl_session_cache has a bug when it attempts to
use
shared memory.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247795,247810#msg-247810

Thank you very much.
I commented the lines ssl_session_timeout and ssl_session_cache and now
everything works fine.

It works well.
thank you very much

You might try;
ssl_session_cache builtin:4000;
which seems to work ok as its processed inside openssl only.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247795,247813#msg-247813

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs