Nginx doesn't accept new connection

Hi there,
I am using nginx as a reverse proxy on a Debian Linux.

The nginx is running on server A, and apache is running on server B.
Server A is a pure proxy, server B is the real web server.

In most of time, nginx works well.
But the HTTP port (80) will stop accepting new connection sometimes.
When it happened, I tried to telnet port 80 from the server by “telnet
localhost 80”, the telnet was just keeping trying but cannot make socket
connection.

I checked the total HTTP connections by “netstat -an | grep 80 | wc
-l”, the number was always less than 2000.

I am using nginx package from Debian Linux, the package was installed
by apt-get.
I added “ulimit -n 65535” into /etc/init.d/nginx to turned the “open
files” limitation.

The problem is not resolved yet. Can anyone help?

Thanks.

Hyacinth

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,216681,216681#msg-216681

On Fri, Oct 14, 2011 at 03:16:39AM -0400, mrkissinger wrote:

connection.

I checked the total HTTP connections by “netstat -an | grep 80 | wc
-l”, the number was always less than 2000.

I am using nginx package from Debian Linux, the package was installed
by apt-get.
I added “ulimit -n 65535” into /etc/init.d/nginx to turned the “open
files” limitation.

The problem is not resolved yet. Can anyone help?

What does “nginx -V” show ?
Are any alerts in error_log ?


Igor S.

Dell-DB:~# nginx -V
nginx: nginx version: nginx/1.1.4
nginx: TLS SNI support enabled
nginx: configure arguments: --prefix=/etc/nginx
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi
–http-log-path=/var/log/nginx/access.log
–http-proxy-temp-path=/var/lib/nginx/proxy
–lock-path=/var/lock/nginx.lock --pid-path=/var/run/nginx.pid
–with-http_gzip_static_module --with-http_ssl_module --with-ipv6
–without-http_browser_module --without-http_geo_module
–without-http_limit_req_module --without-http_limit_zone_module
–without-http_map_module --without-http_memcached_module
–without-http_referer_module --without-http_scgi_module
–without-http_split_clients_module --with-http_stub_status_module
–without-http_ssi_module --without-http_userid_module
–without-http_uwsgi_module
–add-module=/tmp/buildd/nginx-1.1.4/debian/modules/nginx-echo
Dell-DB:~#

nginx error log is empty.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,216681,216683#msg-216683

Any one help, please?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,216681,216690#msg-216690

Resolved. SYN flood.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,216681,216803#msg-216803

Some thing strange happened.

I added 2 ports (80 and 10080) to a vhost in nginx server.

When port 80 is not responsing, port 10080 works well.

It seems that the apache on server B works well, and the nginx on server
A is still working.

The problem is that port 80 is not responsing or responses very slowly.

Any opinions?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,216681,216691#msg-216691

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs