Nginx ask me to watch error log but error log is empty

Hello,

Sometimes I get a 403 error also “Un error occured. Faithfully yours,
nginx.” with nothing in error.log

Already checked
/var/log/nginx/error.log
/usr/local/nginx/logs/error.log

Both of them are chmod in 777

I’m tried to configure rutorrent but I can’t even access, Got a 403
forbiden
… I use domain2.com conf

Any one can help me to understand ?

Here is my conf nginx.conf:

#user nobody;
worker_processes 2;

#error_log logs/error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

#pid logs/nginx.pid;

events {
worker_connections 1024;
}

http {
include mime.types;
default_type application/octet-stream;

#log_format  main  '$remote_addr - $remote_user [$time_local] 

“$request”

# '$status $body_bytes_sent “$http_referer” ’
# ‘"$http_user_agent" “$http_x_forwarded_for”’;

#access_log  logs/access.log  main;

sendfile        on;
#tcp_nopush     on;

#keepalive_timeout  0;
keepalive_timeout  65;

#gzip  on;

server {
listen 80;
server_name localhost;

access_log on;
error_log on;

    #charset koi8-r;

    #access_log  logs/host.access.log  main;

    root   /usr/local/nginx/html;
    #index  index.php;

location /
{
index index.php index.html;
}

location ~ .php$ {
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME
$document_root$fastcgi_script_name;
fastcgi_pass 127.0.0.1:9000;
}
#}

location /rt {
auth_basic “Restricted Area”;
auth_basic_user_file htpasswd;
}

    location /RPC2 {
    scgi_pass   localhost:5000;
    include     scgi_params;
    }


    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   html;
    }

}

server {
listen 80;
server_name domain1.com;

access_log off;
error_log off;

    #charset koi8-r;

    #access_log  logs/host.access.log  main;

    root   /usr/local/nginx/html;
    #index  index.php;

location /
{
index index.html;
}

    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   html;
    }

}

server {
    listen       80;
    server_name  domain2.com;

access_log off;
error_log off;

    #charset koi8-r;

    #access_log  logs/host.access.log  main;

    root   /var/www/d2;
    #index  index.php;

location /
{
index index.php index.html;
auth_basic “Restricted”;
auth_basic_user_file htpasswd;
}

Allow all files in this location to be downloaded

#location ~ ^./files/.$ {}

setup the php-fpm pass-trough

#location / {
location ~ .php$ {
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_pass 127.0.0.1:9000;
}
#}

location /RPC2 {
scgi_pass localhost:5000;
include scgi_params;
}

hide protected files

location
~*.(.htaccess|engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(.php)?|xtmpl)$
{
deny all;
}
#error_page 404 /404.html;

    # redirect server error pages to the static page /50x.html
    #
    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   html;
    }

    # proxy the PHP scripts to Apache listening on 127.0.0.1:80
    #
    #location ~ \.php$ {
    #    proxy_pass   http://127.0.0.1;
    #}

    # pass the PHP scripts to FastCGI server listening on

127.0.0.1:9000
#
#location ~ .php$ {
# root html;
# fastcgi_pass 127.0.0.1:9000;
# fastcgi_index index.php;
# fastcgi_param SCRIPT_FILENAME
/scripts$fastcgi_script_name;
# include fastcgi_params;
#}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #    deny  all;
    #}
}

server {
listen 80;
server_name domain3.com;

access_log off;
error_log off;

    root   /var/www/d3;

    location /
    {
    index   index.php index.html;

    }

    location ~ .php$ {
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param   SCRIPT_FILENAME

$document_root$fastcgi_script_name;
fastcgi_pass 127.0.0.1:9000;
}

    # hide protected files
    location

~*.(.htaccess|engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(.php)?|xtmpl)$
{
deny all;
}

    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   html;
    }


}

}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247597,247597#msg-247597

On Saturday 15 February 2014 16:08:04 okayyyyy wrote:

I’m tried to configure rutorrent but I can’t even access, Got a 403 forbiden
… I use domain2.com conf

Any one can help me to understand ?

Here is my conf nginx.conf:

[…]

server {
listen 80;
server_name localhost;

access_log on;
error_log on;
[…]
server {
listen 80;
server_name domain1.com;

access_log off;
error_log off;
[…]
server {
listen 80;
server_name domain2.com;

access_log off;
error_log off;
[…]
server {
listen 80;
server_name domain3.com;

access_log off;
error_log off;
[…]

So, you should check file with name “off” in working directory.

wbr, Valentin V. Bartenev

Which working directory ? The domain2.com own?

If yes no file with off on it.

My english is not really good sorry

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247597,247599#msg-247599

On Saturday 15 February 2014 16:20:17 okayyyyy wrote:

Which working directory ? The domain2.com own?

If yes no file with off on it.

My english is not really good sorry

Working directory of nginx, see “prefix” option:
http://nginx.org/en/docs/configure.html

Actually that was a hint to you to remove these strange settings,
since it’s not very convenient to keep logs in files with names
“on” and “off”.

Check the docs: http://nginx.org/r/error_log (the “error_log”
directive has no special “on” or “off” flags).

wbr, Valentin V. Bartenev

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs