Nginx and IE

hi,

I have set the gzip flag in the config file to ON to gzip the static
files
on the fly.

Now the problem is this flag is breaking the pages for some version of
IE6.

So, is there any way I can set the flag ON/OFF based on useragent.

Thanks,
Rakesh.

On Sunday 27 January 2008, just starting wrote:

I have set the gzip flag in the config file to ON to gzip the static files
on the fly.

Now the problem is this flag is breaking the pages for some version of IE6.

So, is there any way I can set the flag ON/OFF based on useragent.

v0.6.23 or later

gzip_disable “MSIE [1-6].”;

On 1/27/08, just starting [email protected] wrote:

Rakesh.
http://wiki.codemongers.com/NginxHttpGzipModule#gzip_disable

Have you tried the gzip_disable stanza?
There is an example on the linked page for turning it off for ie 1-6.

hi,

Thanks for the quick reply.

The version I am using is 0.6.22.

Is there any way to upgrade it to 0.6.23 or later or do I have to remove
the
earlier installation and setup again.

Thanks,
Paritosh

On Sunday 27 January 2008, just starting wrote:

Is there any way to upgrade it to 0.6.23 or later or do I have to remove
the earlier installation and setup again.

just install over old version and
http://wiki.codemongers.com/NginxCommandLine#utnbotf

On Mon, Jan 28, 2008 at 09:11:17AM +0530, just starting wrote:

If what I am thinking is true, what is the best possible way to handle
this.(keep the gzip flag OFF?)

There are two ways to work with proxies:

  1. default: responses to the proxied requests are not compressed at all:
    gzip_proxied off;

  2. to allow to cache correctly compressed responses (modern Squids):
    gzip_proxied on;
    gzip_vary on;

On 1/27/08, just starting [email protected] wrote:

cache.

If what I am thinking is true, what is the best possible way to handle
this.(keep the gzip flag OFF?)

Thanks,
Rakesh.

You could probably add an extra vary header, for vary’ing based on
user-agent as well.
Then each browser would get a different cache of that specific object.

You aren’t having problems with html compression though, are you?
My guess is that it is compressed js or css that is causing the problem.
You might want to double check.

If it is just css or js, you may be able to add the additional vary
header based on the mime type of those files, instead of for all html.

Not super sure though. I haven’t dealt with vary headers and
intermediate caches very much…

hi,

I have updated my version to 0.6.25(latest).

I have a question though. Will it work for users behind a proxy server
with
caching enabled.

Suppose at first an user using firefox sends a request for a static page
test.html. Now when another user with IE6 tries to access the same page,
then will the proxy server fetch the uncompressed version or just serve
from
cache.

If what I am thinking is true, what is the best possible way to handle
this.(keep the gzip flag OFF?)

Thanks,
Rakesh.

I dont have much idea abt proxies. So please clear the scene for me.

The 2 options that you provided:

  1. default: responses to the proxied requests are not compressed at all:
    gzip_proxied off;
    It is the safe option, right. If the user is behind a proxy dont use
    gzip.
    Seems fair enough.
  1. to allow to cache correctly compressed responses (modern Squids):
    gzip_proxied on;
    gzip_vary on;
    Now will this work on every condition for all users no matter how their
    proxy has been configured.

Thanks,
Rakesh.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs