Nginx and cgit - upstream prematurely closed FastCGI stdout

I’m trying to setup cgit 0.10 with nginx 1.2.1-2.2 and fastcgi 1.0.3-3.
Unfortunately the reponse is a 502. The following message is written in
the error.log:

[error] 30956#0: *1 upstream prematurely closed FastCGI stdout while
reading response header from upstream, client: **, server: , request:
“GET / HTTP/1.1”, upstream: “fastcgi://unix:/var/run/fcgiwrap.socket:”,
host: "
"

My nginx site is configured as follows:

server {
   ...
   root /var/www/cgit/;
   proxy_redirect off;

   location ~* ^.+\.(css|png|ico)$ {
       expires 30d;
   }

   location / {
         include fastcgi_params;
         fastcgi_param  SCRIPT_FILENAME  /var/www/cgit;
         fastcgi_pass   unix:/var/run/fcgiwrap.socket;
         fastcgi_param    PATH_INFO $uri;
         fastcgi_param    QUERY_STRING  $args;
   }

}

Does anybody have an idea, what is going wrong? I also tried to raise
the timeout limit, but I have no success.

Thanks!
snafu

Hello,
I recently had a lot of trouble similar to this, and discovered that
the fastcgi_param directive is additive - eg a later declaration of
SCRIPT_FILENAME simply adds a second SCRIPT_FILENAME to the fastcgi
parameters. You most likely have SCRIPT_FILENAME set in your “include
fastcgi_params” which means the second one later on is being ignored.

Hello Richard,

thanks for your help. I tried it and a lot of other things without any
success.

But now it works. I just have install the latest fastcgi version from
sources with the same setup as mentioned.

Unfortunately without the advantages of the package management.

Best regards,
Lars

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs