Nginx adds extra chunked header while proxying anytermd


#1

Hi guys,

I have a problem while using nginx to proxy anytermd. anytermd is a
simple
web server which always outputs chunked
data. The following is the data that nginx gave to me:

HTTP/1.1 200 OK
Server: nginx/0.5.36
Date: Fri, 09 May 2008 00:30:37 GMT
Content-Type: text/html
Transfer-Encoding: chunked
Connection: close
Transfer-Encoding: chunked

75f
753


0

0

I saw the doc said that nginx talks http/1.0 to the backend server.How
can I
let the nginx outputing the original data?


#2

On Fri, May 09, 2008 at 08:55:46AM +0800, san wrote:

Transfer-Encoding: chunked
I saw the doc said that nginx talks http/1.0 to the backend server.How can I
let the nginx outputing the original data?

It’s bug in anytermd. It must not send a chunked response for http/1.0
request:
a http/1.0 client does not understand this encoding.


#3

Thanks for your reply. Could you give me a
hint that I can modify the nginx source code to let nginx outputs the
original data?


#4

Dear Igor,

I am suffering from this problem as well, but I am installing nginx from
FreeBSD ports and would not like to mess with its setting.

My question is will this patch make in to the main Nginx release, or
not?

Igor S. wrote:

On Fri, May 09, 2008 at 05:39:39PM +0800, san wrote:

Thanks for your reply. Could you give me a
hint that I can modify the nginx source code to let nginx outputs the
original data?

Try the attached patch: it disables nginx’s chunked response if backend
already sends it chunked.


#5

On Fri, May 09, 2008 at 05:39:39PM +0800, san wrote:

Thanks for your reply. Could you give me a
hint that I can modify the nginx source code to let nginx outputs the
original data?

Try the attached patch: it disables nginx’s chunked response if backend
already sends it chunked.


#6

Igor S. wrote:

On Wed, Aug 20, 2008 at 06:36:07AM +0200, Sharkie L. wrote:

I am suffering from this problem as well, but I am installing nginx from
FreeBSD ports and would not like to mess with its setting.

My question is will this patch make in to the main Nginx release, or
not?

No, that patch had not been commited.

Actually this is Glassfish bug: it must not send chunked response
for HTTP/1.0 request.

Hi Igor,

This is a workaround ? I have the same issue.

I am using nginx 0.7.62 and I not seeing this patch applied.

What can I do ?

Regards,

Camilo Aguilar


#7

On Wed, Aug 20, 2008 at 06:36:07AM +0200, Sharkie L. wrote:

I am suffering from this problem as well, but I am installing nginx from
FreeBSD ports and would not like to mess with its setting.

My question is will this patch make in to the main Nginx release, or
not?

No, that patch had not been commited.

Actually this is Glassfish bug: it must not send chunked response
for HTTP/1.0 request.


#8

Camilo Aguilar wrote:

Igor S. wrote:

On Wed, Aug 20, 2008 at 06:36:07AM +0200, Sharkie L. wrote:

I am suffering from this problem as well, but I am installing nginx from
FreeBSD ports and would not like to mess with its setting.

My question is will this patch make in to the main Nginx release, or
not?

No, that patch had not been commited.

My backend is Mule ESB, it uses Jetty application server