Nginx access_log Buffer size, service not restarting

i am trying to increase the buffer size of access_log

i have tried different options but all giving me errors

access_log /var/log/nginx/www.xxxxx.com/access.log main buffer=1024k;
access_log /var/log/nginx/www.xxxxx.com/access.log compression
buffer=1024k;
access_log /var/log/nginx/www.xxxxx.com/access.log buffer=1024k;

here is the result.

2016/04/27 12:01:40 [emerg] 26411#0: unknown log format “compression” in
/etc/nginx/sites-enabled/default:87
2016/04/27 12:03:29 [emerg] 26470#0: unknown log format “buffer=32k” in
/etc/nginx/sites-enabled/default:87
2016/04/27 12:08:44 [emerg] 26569#0: unknown log format “main” in
/etc/nginx/sites-enabled/default:87

Your expert advice is requested.

Thanks,
Yousuf

Thanks, got it. and it worked too.

Thanks alot.

Hello!

On Wed, Apr 27, 2016 at 05:29:03PM +0500, Muhammad Yousuf K. wrote:

2016/04/27 12:01:40 [emerg] 26411#0: unknown log format “compression” in
/etc/nginx/sites-enabled/default:87
2016/04/27 12:03:29 [emerg] 26470#0: unknown log format “buffer=32k” in
/etc/nginx/sites-enabled/default:87
2016/04/27 12:08:44 [emerg] 26569#0: unknown log format “main” in
/etc/nginx/sites-enabled/default:87

Your expert advice is requested.

Please read the documentation here:

http://nginx.org/en/docs/http/ngx_http_log_module.html

If you are using additional options like “buffer=”, a format of the
log must be specified. You can use predefined “combined” format
if you are ok with it, i.e.:

access_log /path/to/log combined buffer=1m;


Maxim D.
http://nginx.org/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs