Nginx 403 forbidden

Hello everyone,

I have Freebsd 8.2+squid+sarg+nginx server on my production server.I
have
problem to connect nginx internet users web reporting page. When i
connect
to this server via web browser get error : 403 forbidden.

This my nginx-error logs:

*8 directory index of “/home/sqstat/public_html/sarg/” is forbidden,
client:
x.x.x.x, server: localhost, request: “GET /sarg/ HTTP/1.1”, host:
“x.x.x.x:8081”

This my nginx.conf :
#user nobody;
worker_processes 1;

#error_log logs/error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

#pid logs/nginx.pid;

events {
worker_connections 1024;
}

http {
include mime.types;
default_type application/octet-stream;

#log_format  main  '$remote_addr - $remote_user [$time_local] 

“$request”

# '$status $body_bytes_sent “$http_referer” ’
# ‘"$http_user_agent" “$http_x_forwarded_for”’;

#access_log  logs/access.log  main;

sendfile        on;
#tcp_nopush     on;

#keepalive_timeout  0;
keepalive_timeout  65;

#gzip  on;

server {
    listen       12.0.3.233:8081;
    server_name  localhost;

    #charset koi8-r;

    #access_log  logs/host.access.log  main;

    location / {
        root   /home/sqstat/public_html;
        index  index.html index.htm;
    }

    #error_page  404              /404.html;

    # redirect server error pages to the static page /50x.html
    #

error_page 500 502 503 504 /50x.html;
location = /50x.html {
root /usr/local/www/nginx-dist;
}

    # proxy the PHP scripts to Apache listening on 127.0.0.1:80
    #
    #location ~ \.php$ {
    #    proxy_pass   http://127.0.0.1;
    #}

    # pass the PHP scripts to FastCGI server listening on

127.0.0.1:9000
#
#location ~ .php$ {
# root html;
# fastcgi_pass 127.0.0.1:9000;
# fastcgi_index index.php;
# fastcgi_param SCRIPT_FILENAME
/scripts$fastcgi_script_name;
# include fastcgi_params;
#}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #    deny  all;
    #}
}


# another virtual host using mix of IP-, name-, and port-based

configuration
#
#server {
# listen 8000;
# listen somename:8080;
# server_name somename alias another.alias;

#    location / {
#        root   html;
#        index  index.html index.htm;
#    }
#}


# HTTPS server
#
#server {
#    listen       443;
#    server_name  localhost;

#    ssl                  on;
#    ssl_certificate      cert.pem;
#    ssl_certificate_key  cert.key;

#    ssl_session_timeout  5m;

#    ssl_protocols  SSLv2 SSLv3 TLSv1;
#    ssl_ciphers  HIGH:!aNULL:!MD5;
#    ssl_prefer_server_ciphers   on;

#    location / {
#        root   html;
#        index  index.html index.htm;
#    }
#}

This is /home/sqstat/public_html/sarg/ directory permission :

drwxrwxrwx 220 root www 5120 Jan 17 18:57 01Oct2013-01Oct2013
drwxrwxrwx 52 root www 1536 Jan 17 18:30 01Sep2013-01Sep2013
drwxrwxrwx 218 root www 5120 Jan 17 18:58 02Oct2013-02Oct2013
drwxrwxrwx 197 root www 4608 Jan 17 18:32 02Sep2013-02Sep2013
drwxrwxrwx 148 root www 3584 Jan 17 18:09 03Aug2013-03Aug2013
drwxrwxrwx 219 root www 5120 Jan 17 18:59 03Oct2013-03Oct2013
drwxrwxrwx 187 root www 4608 Jan 17 18:33 03Sep2013-03Sep2013

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247009#msg-247009

http://www.nginxtips.com/how-to-enable-nginx-directory-listing/

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247012#msg-247012

Thanks for posting here. But i don’t understand what should be change ?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247022#msg-247022

Maybe you should explain what you expect to happen, if you expect to see
the
contents then that link has the answer.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247023#msg-247023

The error says “directory index of “/home/sqstat/public_html/sarg/” is
forbidden” which means there are no html files there while it tries to
display the contents which is only allowed when you add autoindex on;
see
that link I posted.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247032#msg-247032

Thank you . Fixed.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247033#msg-247033

I am new in linux , because i dont understand your answer. Can you write
where is my problem exactly? What should i do ? Thank you for you

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247009,247028#msg-247028

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs