Nginx-1.9.11

Changes with nginx 1.9.11 09 Feb
2016

*) Feature: TCP support in resolver.

*) Feature: dynamic modules.

*) Bugfix: the $request_length variable did not include size of 

request
headers when using HTTP/2.

*) Bugfix: in the ngx_http_v2_module.


Maxim D.
http://nginx.org/

Hi

starting wit a running nginx/1.9.10 on linux/64

simple build/upgrade to nginx/1.9.11; same config as before

no errors in build

nginx -v
nginx version: nginx/1.9.11

but,

systemctl start
nginx.serviceJob for nginx.service failed. See “systemctl status
nginx.service” and “journalctl -xn” for details.

systemctl status nginx.service -l
nginx.service - The nginx HTTP and reverse proxy server
Loaded: loaded (/etc/systemd/system/nginx.service; enabled)
Active: failed (Result: signal) since Tue 2016-02-09 07:09:47
PST; 24s ago
Process: 4509 ExecStartPre=/usr/local/sbin/nginx -t -c
/usr/local/etc/nginx/nginx.conf (code=killed, signal=FPE)
Main PID: 7589 (code=exited, status=0/SUCCESS)

nginx -t -c /usr/local/etc/nginx/nginx.conf
Floating point exception

in syslog

Feb 9 07:11:07 jimsweb kernel: [393917.665398] traps: nginx[4679]
trap divide error ip:41a95e sp:7ffef4fcbd00 error:0 in
nginx[400000+ed000]

dropback to 1.9.10 works fine

if there’s other info that’ll help, let me know.

Jim

It’s brotli.

Removing

–add-module=/usr/local/src/ngx_brotli

from 1.9.11 config, rebuilding, it’s fixed. Runs ok.

brotli’s OK atm with 1.9.10, but not with 1.9.11

On Tuesday 09 February 2016 11:53:15 locojohn wrote:

I experience the same issue, but I do not have the module reported by
anonymous user installed:

system:~#nginx -t
Floating point exception

dmesg:
[659221.307369] traps: nginx[20028] trap divide error ip:422fba
sp:7ffd8c72a8a0 error:0 in nginx[400000+95d000]

What 3rd-party modules do you have instead? Please, try without them.

wbr, Valentin V. Bartenev

I experience the same issue, but I do not have the module reported by
anonymous user installed:

system:~#nginx -t
Floating point exception

dmesg:
[659221.307369] traps: nginx[20028] trap divide error ip:422fba
sp:7ffd8c72a8a0 error:0 in nginx[400000+95d000]

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264434#msg-264434

It crashes with pagespeed module now. 1.9.10 was working fine.

Andrejs.

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264436#msg-264436

Maxim D.:

Changes with nginx 1.9.11 09 Feb 2016

*) Feature: TCP support in resolver.

the rDNS module (https://www.nginx.com/resources/wiki/modules/rdns/)
don’t compile anymore

cc -c -g -O2 -fstack-protector-strong -Wformat -Werror=format-security
-Wall -I src/core -I src/event -I src/event/modules -I src/os/unix
-I objs -I src/http -I src/http/modules -I src/http/v2 -I src/mail
-o objs/addon/nginx-http-rdns-20140411/ngx_http_rdns_module.o
./nginx-http-rdns-20140411//ngx_http_rdns_module.c
./nginx-http-rdns-20140411//ngx_http_rdns_module.c: In function
‘merge_loc_conf’:
./nginx-http-rdns-20140411//ngx_http_rdns_module.c:217:89: error:
‘ngx_resolver_t’ has no member named ‘udp_connections’
if (conf->conf.enabled && ((core_loc_cf->resolver == NULL) ||
(core_loc_cf->resolver->udp_connections.nelts == 0))) {

                ^

make[2]: ***
[objs/addon/nginx-http-rdns-20140411/ngx_http_rdns_module.o] Error 1

unrelated to above:
attached a patch to correct a manpage warning (not new in this version)

Andreas

On Tue, Feb 09, 2016 at 08:59:42PM +0100, A. Schulze wrote:

cc -c -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wall
^
make[2]: *** [objs/addon/nginx-http-rdns-20140411/ngx_http_rdns_module.o]
Error 1

“connections” should be used instead of “udp_connections”.

[…]


Roman A.

A. Schulze Wrote:

Maxim D.:

Changes with nginx 1.9.11 09
Feb 2016

*) Feature: TCP support in resolver.

the rDNS module (https://www.nginx.com/resources/wiki/modules/rdns/)
don’t compile anymore

It breaks udp in (openresty)Lua as well.

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264444#msg-264444

Roman A.:

compile anymore
if (conf->conf.enabled && ((core_loc_cf->resolver == NULL) ||
(core_loc_cf->resolver->udp_connections.nelts == 0))) {
^
make[2]: *** [objs/addon/nginx-http-rdns-20140411/ngx_http_rdns_module.o]
Error 1

“connections” should be used instead of “udp_connectionss”

Roman,

thanks for the hint. The attached patch solve at least the compile
error.
(still untested if the module still work)

Andreas

Hello Nginx users,

Now available: Nginx 1.9.11 for Windows
https://kevinworthington.com/nginxwin1911 (32-bit and 64-bit versions)

These versions are to support legacy users who are already using Cygwin
based builds of Nginx. Officially supported native Windows binaries are
at
nginx.org.

Announcements are also available here:
Twitter http://twitter.com/kworthington
Google+ https://plus.google.com/+KevinWorthington/

Thank you,
Kevin

Kevin W.
kworthington @ (gmail] [dot} {com)
http://kevinworthington.com/
http://twitter.com/kworthington
https://plus.google.com/+KevinWorthington/

I also get a compile error related to Pagespeed:

            -o objs/addon/src/ngx_message_handler.o \

/root/ngx_pagespeed-release-1.10.33.4-beta/src/ngx_message_handler.cc
cc -c -pipe -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror
-g
-march=i686 -D_GLIBCXX_USE_CXX11_ABI=0 -I src/core -I src/event -I
src/event/modules -I src/os/unix -I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include -I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/chromium/src
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/google-sparsehash/src
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/google-sparsehash/gen/arch/linux/ia32/include
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/protobuf/src
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/re2/src
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/out/Debug/obj/gen
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/out/Debug/obj/gen/protoc_out/instaweb
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/apr/src/include
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/aprutil/src/include
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/apr/gen/arch/linux/ia32/include
-I
/root/ngx_pagespeed-release-1.10.33.4-beta/psol/include/third_party/aprutil/gen/arch/linux/ia32/include
-I /usr/include/libxml2 -I objs -I src/http -I src/http/modules -I
src/http/v2 -I src/mail
-o objs/addon/src/ngx_pagespeed.o \

/root/ngx_pagespeed-release-1.10.33.4-beta/src/ngx_pagespeed.cc
/root/ngx_pagespeed-release-1.10.33.4-beta/src/ngx_pagespeed.cc:3133:1:
error: deprecated conversion from string constant to ‘char*’
[-Werror=write-strings]
};
^
/root/ngx_pagespeed-release-1.10.33.4-beta/src/ngx_pagespeed.cc:3148:1:
error: deprecated conversion from string constant to ‘char*’
[-Werror=write-strings]
};
^
cc1plus: all warnings being treated as errors
make[1]: *** [objs/addon/src/ngx_pagespeed.o] Error 1
make[1]: Leaving directory `/root/temp/nginx-1.9.11’
make: *** [build] Error 2

Hello!

On Wed, Feb 10, 2016 at 12:15:53PM +0100, Lukas T. wrote:

Apply this patch:
http://hg.nginx.org/nginx/rev/ff1e625ae55b

Or pull latest source code from the repository.

Trivial workaround for build failures due to warnings is to use
-Wno-error, e.g.:

./configure --with-cc-opt="-Wno-error" …

In this particular case, -Wno-write-strings can be used instead,
e.g.:

./configure --with-cc-opt="-Wno-write-strings" …


Maxim D.
http://nginx.org/

I’m having issues with 1.9.11. With the exact same build configuration
as I
used for 1.9.10, and the exact same config files for nginx - I am now
getting this when I run nginx -t at the command-line:

nginx: [emerg] unknown directive “charset” in /etc/nginx/nginx.conf:62
nginx: configuration file /etc/nginx/nginx.conf test failed

When I comment out that particular line in the nginx.conf file, I am
then
presented with another error:

nginx: [emerg] unknown directive “add_header” in /etc/nginx/ssl.conf:28
nginx: configuration file /etc/nginx/nginx.conf test failed

Not sure why I’m observing this behavior, when the exact same build
configuration for 1.9.10 worked just fine. It seems like some of the
core
modules (e.g.: ngx_http_charset_module, ngx_http_headers_module) are
somehow
missing from my build? Am I missing something? These are the
module-related flags I provide to “./configure”:

–with-pcre-jit
–with-ipv6
–with-file-aio
–with-http_ssl_module
–with-http_v2_module
–with-http_realip_module
–without-http_map_module
–without-http_memcached_module
–without-http_autoindex_module
–without-http_split_clients_module
–without-http_upstream_ip_hash_module
–without-http_upstream_least_conn_module
–without-http_upstream_keepalive_module
–without-http_userid_module
–without-http_empty_gif_module
–without-http_auth_basic_module
–without-mail_pop3_module
–without-mail_smtp_module
–without-mail_imap_module
–without-http_uwsgi_module
–without-http_scgi_module
–without-http_browser_module
–add-module=$HOME/naxsi-${NAXSI_VER}/naxsi_src
–add-module=$HOME/ngx_pagespeed-${PAGESPEED_VER}-beta

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264481#msg-264481

I also get a compile error related to Pagespeed:
[…]
/root/ngx_pagespeed-release-1.10.33.4-beta/src/ngx_pagespeed.cc:3148:1:
error: deprecated conversion from string constant to char*
[-Werror=write-strings]
};
^
cc1plus: all warnings being treated as errors

Apply this patch:
http://hg.nginx.org/nginx/rev/ff1e625ae55b

Or pull latest source code from the repository.

Regards,

Lukas

./configure --with-cc-opt="-Wno-write-strings" …

When I tried this, I get:

Starting nginx: nginx: [emerg] unknown directive “charset” in
/etc/nginx/nginx.conf:15
nginx: configuration file /etc/nginx/nginx.conf test failed


But I just saw your other reply re the ngx_pagespeed changeset, so
that’s
what I’ll look into

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264484#msg-264484

A. Schulze:

The attached patch solve at least the compile error.
now also verified the module work with nginx-1.9.11

Andreas

Hello!

On Wed, Feb 10, 2016 at 09:30:49PM -0500, qbitx wrote:

nginx: [emerg] unknown directive “add_header” in /etc/nginx/ssl.conf:28
nginx: configuration file /etc/nginx/nginx.conf test failed

Not sure why I’m observing this behavior, when the exact same build
configuration for 1.9.10 worked just fine. It seems like some of the core
modules (e.g.: ngx_http_charset_module, ngx_http_headers_module) are somehow
missing from my build? Am I missing something? These are the
module-related flags I provide to “./configure”:

[…]

–add-module=$HOME/naxsi-${NAXSI_VER}/naxsi_src
–add-module=$HOME/ngx_pagespeed-${PAGESPEED_VER}-beta

Most likely this is ngx_pagespeed 3rd party module which causes
the problem you are seeing. It tries to do unsupported
modifications of order of modules, and was beaten by internal
changes in configure scripts in 1.9.11. Quick look suggests the
problem is expected to be fixed by this changeset:

https://github.com/pagespeed/ngx_pagespeed/commit/daa6031294403a25a4fd2f4c7b6a16a349df8af2

That is, either update ngx_pagespeed to the latest git checkout,
or compile nginx without it.


Maxim D.
http://nginx.org/

With the release of ngx_pagespeed 1.10.33.5, I’m no longer having any
make
issues with 1.9.11

Posted at Nginx Forum:
https://forum.nginx.org/read.php?2,264422,264581#msg-264581

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs