Nginx-1.0.11

Changes with nginx 1.0.11 15 Dec
2011

*) Change: now double quotes are encoded in an "echo" SSI-command
   output.
   Thanks to Zaur Abasmirzoev.

*) Feature: the "image_filter_sharpen" directive.

*) Bugfix: a segmentation fault might occur in a worker process if 

SNI
was used; the bug had appeared in 1.0.9.

*) Bugfix: SIGWINCH signal did not work after first binary upgrade; 

the
bug had appeared in 1.0.9.

*) Bugfix: the "If-Modified-Since", "If-Range", etc. client request
   header lines might be passed to backend while caching; or not 

passed
without caching if caching was enabled in another part of the
configuration.

*) Bugfix: in the "scgi_param" directive, if complex parameters were
   used.

*) Bugfix: "add_header" and "expires" directives did not work if a
   request was proxied and response status code was 206.

*) Bugfix: in the "expires @time" directive.

*) Bugfix: in the ngx_http_flv_module.
   Thanks to Piotr S..

*) Bugfix: in the ngx_http_mp4_module.

*) Bugfix: nginx could not be built on FreeBSD 10.

*) Bugfix: nginx could not be built on AIX.

Maxim D.

Hello Nginx U.s,

Just released: Nginx 1.0.11 For Windows http://goo.gl/v0Xqm (32-bit
and 64-bit versions)

These versions are to support legacy users who are already using
Cygwin based builds of Nginx. Official Windows binaries are at
nginx.org

Thank you,
Kevin

Kevin W.
kworthington *@~ #gmail} [dot) {com]
http://www.kevinworthington.com/

On 16.12.2011, at 12:34, Antoine B. wrote:

Maxim,

That might very well be due to my lack of expertise on debians, but I
was not expecting version 1.0.11-1 to have ‘’ (was expecting
stable):

Add public key as described in
http://mailman.nginx.org/pipermail/nginx/2011-December/030918.html

Maxim,

That might very well be due to my lack of expertise on debians, but I
was not expecting version 1.0.11-1 to have ‘’ (was expecting
stable):

~# aptitude versions nginx
p 0.7.67-3 stable
990
p 1.0.11-1
500
p 1.1.8-2 testing
500

I had to explicitly chose 1.0.11 which I do not remember doing when I
installed 1.0.10 on another server from the same repo (deb
http://nginx.org/packages/debian/ squeeze nginx).

Actually, I checked on the other machine (with 1.0.10) and it still
has the “old” packages DB and shows:
~# aptitude versions nginx
p 0.7.67-3 stable
990
i 1.0.10-1 stable
990
p 1.1.8-1 testing
500

A.

On Fri, Dec 16, 2011 at 2:22 AM, Kevin W.

Hello!

On Fri, Dec 16, 2011 at 09:34:29AM +0100, Antoine B. wrote:

I had to explicitly chose 1.0.11 which I do not remember doing when I
installed 1.0.10 on another server from the same repo (deb
http://nginx.org/packages/debian/ squeeze nginx).

Actually, I checked on the other machine (with 1.0.10) and it still
has the “old” packages DB and shows:
~# aptitude versions nginx
p 0.7.67-3 stable 990
i 1.0.10-1 stable 990
p 1.1.8-1 testing 500

Please make sure you have signing key imported, see instructions
from Sergey B. here:

http://mailman.nginx.org/pipermail/nginx/2011-December/030918.html

Maxim D.

Maxim, Sergey,

With signing key it works much better.

Thanks a lot.

A.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs